tcl-rivet-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Damon Courtney <da...@your.unreality.com>
Subject Re: package require ***
Date Thu, 16 Jan 2003 00:36:09 GMT
> @ashland [~/workshop/tcl-rivet/src] $ ldd mod_rivet.so
>         libtcl8.4.so.0 => /usr/lib/libtcl8.4.so.0 (0x6fef3000)
>         libdl.so.2 => /lib/libdl.so.2 (0x6fed0000)
>         libm.so.6 => /lib/libm.so.6 (0x6fe39000)
>         libcrypt.so.1 => /lib/libcrypt.so.1 (0x6fded000)
>         libc.so.6 => /lib/libc.so.6 (0x6fc92000)
>         /lib/ld.so.1 => /lib/ld.so.1 (0x08000000)
> 
> If it's picking up the wrong one... hrm.  Well, let's see if it is,
> then we can deal with it.  On Linux, you can set LD_LIBRARY_PATH to
> make it choose a different lib, for instance.

    You can do the same on FreeBSD or any *NIX I've been on.
I always specify LD_LIBRARY_PATH (since my Tcl is installed in
non-standard locations).

Damon


---------------------------------------------------------------------
To unsubscribe, e-mail: rivet-dev-unsubscribe@tcl.apache.org
For additional commands, e-mail: rivet-dev-help@tcl.apache.org


Mime
View raw message