tcl-rivet-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Rankin" <jran...@oneil.com>
Subject RE: package require ***
Date Tue, 14 Jan 2003 12:44:59 GMT
It looks like the answer lay in my $auto_path, which is:

/home/jrankin/apache/rivet/rivet-tcl /usr/sfw/lib/tcl8.3 /usr/sfw/lib ./lib
/home/jrankin/apache/rivet/packages
/home/jrankin/apache/rivet/packages-local .

It appears that it's using the lib directories for the wrong tcl. I want it
to use /usr/local/ActiveTcl/lib, and it's using the default libs that came
with solaris 9 (/usr/sfw/lib). I verified that I could access libraries in
that dir without errors.

I'm confused in that I know it used ActiveTcl when I compiled. I guess the
only issue now is how to 'tell' Rivet to include the proper lib directory.
As usual, help would be appreciated.

- Jeff

> -----Original Message-----
> From: David N. Welton [mailto:davidw@dedasys.com]
> Sent: Monday, January 13, 2003 4:30 PM
> To: rivet-dev@tcl.apache.org
> Cc: Karl Lehenbauer
> Subject: Re: package require ***
>
>
>
> A few more questions:
>
> Do tclsh and Rivet both use the same Tcl library?
>
> What are the values of [info library], $auto_path and the like?
>
> --
> David N. Welton
>    Consulting: http://www.dedasys.com/
>      Personal: http://www.dedasys.com/davidw/
> Free Software: http://www.dedasys.com/freesoftware/
>    Apache Tcl: http://tcl.apache.org/
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: rivet-dev-unsubscribe@tcl.apache.org
> For additional commands, e-mail: rivet-dev-help@tcl.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: rivet-dev-unsubscribe@tcl.apache.org
For additional commands, e-mail: rivet-dev-help@tcl.apache.org


Mime
View raw message