taverna-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michele Donato <mdon...@stanford.edu>
Subject Re: Taverna Workbench crashes on Mac OS
Date Tue, 07 Feb 2017 17:34:01 GMT
Hi Alan,

Thanks for your reply.

I tried the Enterprise version, but unfortunately that version does not work either.
I tried it on a very similar Mac Book Pro (Sierra, 15”, retina, mid 2016) and it does not
work on that machine either (both Core and Enterprise).

The curious thing is that one of my colleagues has a MacBook pro 13” (with Sierra, retina,
2014) and it works on that machine.

Looking for the particular exception, I found out some posts that link it to the graphic card,
stating that it could happen when the mac works with the discrete card. That would explain
why the 13” does not have the problem, as it is always working with the Iris card.

Therefore, I did this: I downloaded the application gfxCardStatus, which allows to manually
choose the card to be used, and re-started Taverna, and it started without a problem.

Unfortunately this is a deal breaker for me, as the integrated graphic card is not able to
drive efficiently the screen I use in the lab.

One positive aspect is that the app seems to stay open after I switch back to the discrete
card. This means that I need to switch to integrated, start Taverna, switch back to discrete,
then connect my monitor. Not optimal, but it works.

Any idea how to fix this to have it work without the graphic card switcharoo trick?

Thanks

Michele

On Feb 7, 2017, at 01:54, alaninmcr <alaninmcr@googlemail.com<mailto:alaninmcr@googlemail.com>>
wrote:

On 06/02/2017 19:11, Michele Donato wrote:
Hello.

Hello

I am trying to integrate Taverna workbench in our lab workflows, but I
cannot even open it. After installation I try to open it but it crashes
immediately

This is the header of the error:

Process:               JavaApplicationStub [37612]
Path:                  /Applications/Taverna Workbench Core
2.5.0.app/Contents/MacOS/JavaApplicationStub
Identifier:            net.sf.taverna.t2.workbench
Version:               2.5.0 (2.5.0)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           JavaApplicationStub [37612]
User ID:               501

Date/Time:             2017-02-06 11:05:06.749 -0800
OS Version:            Mac OS X 10.12.2 (16C67)

My colleague tried on a similar system and the software crashes on his
system too.
I tried to google the issue but no result was relevant.

Any tip?

Sorry to hear you are having problems. Can you try with another version of the workbench e.g.
the enterprise edition

http://www.taverna.org.uk/download/workbench/2-5/enterprise/#download-mac

That will tell us whether it is a problem that is likely to be specific to the core app.

Michele

Alan

Mime
View raw message