taverna-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stian Soiland-Reyes <soiland-re...@cs.manchester.ac.uk>
Subject Re: Galaxy integration and / or web front end
Date Tue, 09 Dec 2014 10:16:06 GMT
So you are talking about https://trac.nbic.nl/elabfactory/wiki/eGalaxy

Just as a quick note - this is not a library that has been made by the
Taverna project - although Finn Bacall in the myGrid office has
earlier been involved. I have copied in Kostas and Marco Roos which
might know more.


I think you are right in that the calls to the Ruby libraries are
outdated - how to set inputs is one of the things that has been since
changed (before I think it was done as a file upload). The latest
version of the library is 1.2.0  - I am not sure which installation of
Taverna server 0.6.1 would work with
-https://github.com/myGrid/t2-server-gem/tree/0.6.1 says 2.2a1 which
is very old. The 0.6.1 library is also written for Ruby 1.8.


See https://github.com/myGrid/t2-server-gem for documentation about
the t2 server gem.


In theory there should not be any need for the Taverna Server as
Galaxy could call the Taverna Command line directly - I am not sure
myself what was the reason for going through the server - perhaps to
locate it outside the Galaxy node?

http://dev.mygrid.org.uk/wiki/display/tav250/Command+Line+Tool


Perhaps an idea would be to fix the taverna-2-galaxy tool to use the
command line directly - or at least to use the 1.2.0 library?


Have you been able to find the source code? I can't see it at
https://trac.nbic.nl/elabfactory/wiki/eGalaxy - although it is
included in the gem from
https://rubygems.org/gems/workflow-to-galaxy/versions/0.3.5 it would
be nice to find the repository.




There is a web front-end for Taverna Server called Taverna Player,
which is a Ruby on Rails plugin. It is however updated to the latest
version of the t2-server-gem and should work.
https://github.com/myGrid/taverna-player

There is an example application using this plugin at
https://github.com/myGrid/taverna-player-portal


There are other web frontends that are more customized for particular
workflows - e.g.

http://mrmpeptidepicker.proteincentre.com/


or for designing workflows running on grid resources:

http://onlinehpc.com/


Perhaps others on the list have more examples?

On 8 December 2014 at 15:08, Andrea Schafferhans
<andrea.schafferhans@rostlab.org> wrote:
> Dear Taverna users,
>
> I am new to taverna, so apologies if this has been asked before, but I have been pointed
to this mailing list by the support team.
>
> [Short version:]
>
> We are currently working on a project to make computation services available through
Taverna and/or Galaxy. We have tried to use the taverna-2-galaxy tool in order to import taverna
workflows into Galaxy, but it looks like they do not work with the current version of Taverna.
> Apparently the Taverna interface has changed too much since the Galaxy integration was
developed, so the workflow cannot be run with the given integration solution. Before we start
building our own connector, I wanted to check the status of the Taverna/Galaxy integration.
Are you aware of any efforts to update the taverna-2-galaxy tool?
>
> [More details:]
> The Taverna workflow can be displayed and “run” from Galaxy, but it does not actually
execute.
> This is the error you get with t2-server version 0.61.
>
> ./ruby Workflow1.rb
> /etc/ruby3/lib/ruby/gems/2.1.0/gems/t2-server-0.6.1/lib/t2-server/server.rb:456:in `parse_description':
undefined method `attributes' for nil:NilClass (NoMethodError)
> from /etc/ruby3/lib/ruby/gems/2.1.0/gems/t2-server-0.6.1/lib/t2-server/server.rb:83:in
`initialize'
> from /etc/ruby3/lib/ruby/gems/2.1.0/gems/t2-server-0.6.1/lib/t2-server/server.rb:120:in
`new'
> from /etc/ruby3/lib/ruby/gems/2.1.0/gems/t2-server-0.6.1/lib/t2-server/server.rb:120:in
`connect'
> from /etc/ruby3/lib/ruby/gems/2.1.0/gems/t2-server-0.6.1/lib/t2-server/run.rb:88:in `create'
> from Workflow1.rb:135:in `'
>
> If you try to trace it back, you find that the ruby-file server.rb parses a string provided
by the taverna-server for a certain attribute.
> Since this attribute does not exist in the string, the parsing returns a nil-object and
as soon as this nil-object is used in the subsequent code it crashes.
>
> We also tried to use t2-server 1.2 instead. At first, this produces an authentication
error (which we could fix), since workflow-to-galaxy does not pass user and password properly
to t2-server. But workflow-to-galaxy also does not use the new inputport API used in the new
version of t2-server. Particularly, it uses
> a function set_input which does not exist in the new verison of t2-server.
>
>
> We are also interested in a web front end for Taverna. It looks like there is one, but
that probably uses the same integration as the galaxy tool. Is that guess correct?
>
> So, we’d be grateful for any hints from anyone who is using the Taverna-Galaxy integration
and/or anyone who has a web front end for end-users of finished workflows.
>
>     Thanks!
>
>         Andrea
>
>
>
>
> --
> Dr. Andrea Schafferhans
>
> I12, Chair of Prof. Rost
> Technische Universität München
> Fakultät für Informatik
> Boltzmannstraße 3, 85748 Garching, Germany
>
> URL:    http://www.rostlab.org/~andrea/
> Mail:   andrea.schafferhans@rostlab.org
> Phone:  0049 89 289 17833
> Fax:    0049 89 289 19414
> Room:   01.09.055
>
> "Those who would give up essential Liberty to obtain a little temporary Safety, deserve
neither Liberty nor Safety."  Benjamin Franklin (1775)
>



-- 
Stian Soiland-Reyes, myGrid team
School of Computer Science
The University of Manchester
http://soiland-reyes.com/stian/work/ http://orcid.org/0000-0001-9842-9718

Mime
View raw message