taverna-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrea Schafferhans <andrea.schafferh...@rostlab.org>
Subject Galaxy integration and / or web front end
Date Mon, 08 Dec 2014 15:08:49 GMT
Dear Taverna users,

I am new to taverna, so apologies if this has been asked before, but I have been pointed to
this mailing list by the support team. 

[Short version:]

We are currently working on a project to make computation services available through Taverna
and/or Galaxy. We have tried to use the taverna-2-galaxy tool in order to import taverna workflows
into Galaxy, but it looks like they do not work with the current version of Taverna. 
Apparently the Taverna interface has changed too much since the Galaxy integration was developed,
so the workflow cannot be run with the given integration solution. Before we start building
our own connector, I wanted to check the status of the Taverna/Galaxy integration. Are you
aware of any efforts to update the taverna-2-galaxy tool? 

[More details:]
The Taverna workflow can be displayed and “run” from Galaxy, but it does not actually
execute. 
This is the error you get with t2-server version 0.61.

./ruby Workflow1.rb
/etc/ruby3/lib/ruby/gems/2.1.0/gems/t2-server-0.6.1/lib/t2-server/server.rb:456:in `parse_description':
undefined method `attributes' for nil:NilClass (NoMethodError)
from /etc/ruby3/lib/ruby/gems/2.1.0/gems/t2-server-0.6.1/lib/t2-server/server.rb:83:in `initialize'
from /etc/ruby3/lib/ruby/gems/2.1.0/gems/t2-server-0.6.1/lib/t2-server/server.rb:120:in `new'
from /etc/ruby3/lib/ruby/gems/2.1.0/gems/t2-server-0.6.1/lib/t2-server/server.rb:120:in `connect'
from /etc/ruby3/lib/ruby/gems/2.1.0/gems/t2-server-0.6.1/lib/t2-server/run.rb:88:in `create'
from Workflow1.rb:135:in `'

If you try to trace it back, you find that the ruby-file server.rb parses a string provided
by the taverna-server for a certain attribute.
Since this attribute does not exist in the string, the parsing returns a nil-object and as
soon as this nil-object is used in the subsequent code it crashes.

We also tried to use t2-server 1.2 instead. At first, this produces an authentication error
(which we could fix), since workflow-to-galaxy does not pass user and password properly to
t2-server. But workflow-to-galaxy also does not use the new inputport API used in the new
version of t2-server. Particularly, it uses
a function set_input which does not exist in the new verison of t2-server.


We are also interested in a web front end for Taverna. It looks like there is one, but that
probably uses the same integration as the galaxy tool. Is that guess correct? 

So, we’d be grateful for any hints from anyone who is using the Taverna-Galaxy integration
and/or anyone who has a web front end for end-users of finished workflows. 

    Thanks!

        Andrea




--
Dr. Andrea Schafferhans

I12, Chair of Prof. Rost
Technische Universität München
Fakultät für Informatik
Boltzmannstraße 3, 85748 Garching, Germany

URL:	http://www.rostlab.org/~andrea/
Mail:	andrea.schafferhans@rostlab.org
Phone:	0049 89 289 17833
Fax:   	0049 89 289 19414
Room:	01.09.055

"Those who would give up essential Liberty to obtain a little temporary Safety, deserve neither
Liberty nor Safety."  Benjamin Franklin (1775) 


Mime
View raw message