taverna-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Warhurst <alexander.warhu...@postgrad.manchester.ac.uk>
Subject Porting the JsonPath Activity
Date Sun, 16 Jul 2017 12:49:52 GMT
Hi,


I am trying to port the JsonPath activity (https://github.com/taverna/taverna-jsonpath-activity)
from Taverna 2 to Taverna 3 Command Line.


The error I keep getting is:


ERROR 2017-07-16 12:33:35,629 (org.springframework.osgi.extender.internal.activator.ContextLoaderListener:52)
- Application context refresh failed (OsgiBundleXmlApplicationContext(bundle=org.apache.taverna.commandline.taverna-commandline-common,
config=osgibundle:/META-INF/spring/*.xml))
org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'commandLineTool'
defined in URL [bundle://128.0:0/META-INF/spring/taverna-commandline-common-context.xml]:
Invocation of init method failed; nested exception is java.lang.IndexOutOfBoundsException:
Could not find configuration for Activity http://ns.taverna.org.uk/2010/xml/t2flow/raven/net.sf.taverna.t2.activities/jsonpath-activity/0.0.1/net.sf.taverna.t2.activities.jsonpath.JsonPathActivity
"state1"

(Note: I have tried to keep the the activity URI as http://ns.taverna.org.uk/2010/xml/t2flow/raven/net.sf.taverna.t2.activities/jsonpath-activity/0.0.1/net.sf.taverna.t2.activities.jsonpath.JsonPathActivity,
so that I don't have to edit the existing workflows I am using).

It seems the problem is that it can't find the activity configuration, so bean creation fails,
but I don't know why.

I have added the plugin into the lib directory, and added it to the ApplicationProfile.xml
(I think this is how you add plugins to the incubator version).

Having tried starting from the archetype, using the porting guide, and using the apache-taverna-common-activities
repository as a reference I have been unable to get past this point.

I haven't tried porting the activity UI, as I don't believe this is relevant for the command
line version (could be wrong, feel free to enlighten me).

Any advice you could offer would be most appreciated.

Thanks,

Alex

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message