taverna-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ian Dunlop (JIRA)" <j...@apache.org>
Subject [jira] [Created] (TAVERNA-958) Minimum API needs changed
Date Wed, 23 Mar 2016 16:01:25 GMT
Ian Dunlop created TAVERNA-958:
----------------------------------

             Summary: Minimum API needs changed
                 Key: TAVERNA-958
                 URL: https://issues.apache.org/jira/browse/TAVERNA-958
             Project: Apache Taverna
          Issue Type: Bug
          Components: Taverna Mobile
    Affects Versions: 1.0
            Reporter: Ian Dunlop


The app contains code which targets a higher API version than the minimum but there are no
guards in place to stop it breaking.

eg From DashboardMainActivity

Intent workflowSelectIntent =										new Intent(Intent.ACTION_GET_CONTENT)										.setDataAndTypeAndNormalize(Uri.parse(String.format("%s%s%s",
Environment.getExternalStorageDirectory(),
File.separator, APP_DIRECTORY_NAME)),
"application/vnd.taverna.t2flow+xml");

"setDataAndTypeAndNormalize" is API 16 but the app is now API 14 minimum.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message