tapestry-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Borut BolĨina <borut.bolc...@gmail.com>
Subject T5.2.6 HTML 5 validation fails
Date Thu, 18 Aug 2011 13:39:16 GMT
Hello,

just out of curiosity I tried validating one Tapestry 5.2.5 page against
HTML and  some elements get rendered like this

<link type="text/css" rel="stylesheet"
href="/foo-bar/assets/1.0-SNAPSHOT/core/default.css"></link>
or
<meta content="Apache Tapestry Framework (version 5.2.6)"
name="generator"></meta>


To be HTML 5 valid, it should render like this

<link type="text/css" rel="stylesheet"
href="/foo-bar/assets/1.0-SNAPSHOT/core/default.css"/>
and
<meta content="Apache Tapestry Framework (version 5.2.6)" name="generator"/>

The HTML begins with
<!DOCTYPE html>

I tried validating with Firefox plugin (
https://addons.mozilla.org/sl/firefox/addon/html-validator/) and at
http://validator.w3.org

Is it possible to configure this element closing?

Regards,
Borut

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message