tapestry-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Katia Aresti <katiaare...@gmail.com>
Subject Re: Tapestry Not running in Weblogic
Date Thu, 04 Nov 2010 07:13:04 GMT
Hi,

I had problems with weblogic 11g XML libraries and other fw too - as axis 2
for example. Laurent's solution works to make your application load
Tapestry's web-inf classes first. However, you might find side classloader
errors if you use, for example, shared libraries containing the same classes
- jars than in your web-inf.
If possible, I would consider moving to Tapestry 5.2 (release will soon
arrive) first rather than configuring weblogic this way.

Katia

2010/11/4 Guerin Laurent <lguerin@sopragroup.com>

> Hi,
>
> The workaround is :
>
> 1. add
>        <container-descriptor>
>                <prefer-web-inf-classes>true</prefer-web-inf-classes>
>        </container-descriptor>
> to the weblogic.xml of the war file.
> 2. wrap the war in an ear file
> 3. add a weblogic-application.xml file to the META-INF directory of the ear
> which contains
>  <application-param>
>  <param-name>javax.xml.stream.XMLInputFactory</param-name>
>  <param-value>com.ctc.wstx.stax.WstxInputFactory</param-value>
>  </application-param>
> 4. deploy the ear instead of the war.
>
> Work for me on weblogic 10.x
>
> Original message :
> http://www.mail-archive.com/users@tapestry.apache.org/msg37792.html
>
>
>
>
> Envoyé de mon iPhone
>
> Le 4 nov. 2010 à 02:16, "Howard Lewis Ship" <hlship@gmail.com> a écrit :
>
> > Please search the mail archives; others have hit this and there is a
> > workaround.
> >
> > Consider Tapestry 5.2.2, which is in late beta, and will not have this
> > problem.
> >
> > On Wed, Nov 3, 2010 at 6:11 PM, Anas Mughal <anasmughal@yahoo.com>
> wrote:
> >
> >>
> >> We are evaluating Tapestry for our project. The application is supposed
> to
> >> run on Weblogic. When we deploy our sample application built with
> Tapestry
> >> 5.1.0.5 to Weblogic 11g, we get the following error:
> >> weblogic.xml.stax.XMLStreamInputFactory cannot be cast to
> >> org.codehaus.stax2.XMLInputFactory2
> >>
> >> I see a bug logged for this issue at:
> >> https://issues.apache.org/jira/browse/TAP5-745
> >>
> >>
> >> Has this issue been resolved?
> >> Is there a place where I could downloaded a patch for this?
> >>
> >>
> >> Thank you in advance.
> >> --
> >> Anas Mughal
> >> http://anas-mughal.com
> >>
> >>
> >>
> >
> >
> >
> >
> > --
> > Howard M. Lewis Ship
> >
> > Creator of Apache Tapestry
> >
> > The source for Tapestry training, mentoring and support. Contact me to
> learn
> > how I can get you up and productive in Tapestry fast!
> >
> > (971) 678-5210
> > http://howardlewisship.com
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message