tapestry-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Inge Solvoll <inge.tapes...@gmail.com>
Subject Re: [ANNOUNCE] Tapestry 5.1.0.2
Date Fri, 03 Apr 2009 10:05:34 GMT
My biggest problem was that equanda haven't released something that is
compatible with 5.1. I guess I'll have to wait for them to catch up, or use
other components, my equanda usage is very limited.

I'm amazed at how T5 keeps addressing my key concerns :)

Problem: I had to duplicate tml content in my subclassed components.
Solution: T5 suddenly comes with a feature of overriding specific parts.

Problem: I was annoyed that I had to do plumbing/copy-paste on encoders in
loops. The loop encoder concept is IMHO one of the more non-intuitive parts
of the framework, which I had to spend some time teaching my colleagues, and
they still need a recipe to do it.
Solution: T5 plans(?) to eliminate this by providing encoders as
contributions in IOC. Hope this comes through! :)

Inge

On Fri, Apr 3, 2009 at 11:38 AM, Blower, Andy <Andy.Blower@proquest.co.uk>wrote:

> So, is Maven ignoring the sha1 problem or is Ivy miscalculating this one
> for some reason?
>
> Regarding the dependencies, I also have an issue that I'd not spotted
> before. Ivy can't find javassist-3.9.0.GA.jar in the maven2 repositories. I
> can't find it with a browser either. (e.g.
> http://repo1.maven.org/maven2/javassist/javassist/) So, that's breaking my
> build too.
>
>
> > -----Original Message-----
> > From: Massimo Lusetti [mailto:mlusetti@gmail.com]
> > Sent: 03 April 2009 10:18
> > To: Tapestry users
> > Subject: Re: [ANNOUNCE] Tapestry 5.1.0.2
> >
> > On Fri, Apr 3, 2009 at 11:05 AM, Blower, Andy
> > <Andy.Blower@proquest.co.uk> wrote:
> >
> > > I'm having two issues stopping me with 5.1.0.2, the first I mailed
> > the list about a few days ago but I've had no response so far.
> > (http://www.nabble.com/T5.1.0.2-problem-with-TestableRequestImpl-
> > td22805378.html)
> >
> > Yep... i must admit that i too have run into this, also with tests for
> > the chenillekit-access module, fortunately I've switched to use
> > selenium before,  but you're right, there's an issue with PageTester.
> >
> > > What is this stax2 thingy and why does Tapestry 5.1 need it? Does
> > anyone using maven get this problem? Is there anything we can do to fix
> > this?
> >
> > stax2 use new api for XML processing which 5.1 dom processing
> > leverage. I don't had any issue i remember and using maven 2.0.9 here
> >
> > --
> > Massimo
> > http://meridio.blogspot.com
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@tapestry.apache.org
> > For additional commands, e-mail: users-help@tapestry.apache.org
> >
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tapestry.apache.org
> For additional commands, e-mail: users-help@tapestry.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message