tapestry-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Hillyerd" <ja...@hillyerd.com>
Subject Re: [T5] Palette NPE
Date Wed, 03 Dec 2008 20:33:41 GMT
Probably not related to your problem, but I was seeing an NPE from the exact
same line of code when passing the palette a Set (instead of a List).

-james

On Wed, Dec 3, 2008 at 11:27 AM, zack1403 <zack.manning@gmail.com> wrote:

>
> Ive overridden both equals and hashCode (neither were overridden before)
> and
> have been waiting for the issue to reproduce.  It is very intermittent and
> a
> simple f5 makes it go away which is frustrating.  I also am trying using
> GenericSelectModel as the encoder and model which might make the issue go
> away.  Ill follow up if that fixes it.  Thanks!
>
> Zack
>
>
> Nicolas Charles wrote:
> >
> > I just had this issue; it was because the object overrided the "equals"
> > method, but not "hashCode", hence the selected object couldn't be found
> > in the selected set.
> >
> > Nick
> >
> >
>
> --
> View this message in context:
> http://www.nabble.com/-T5--Palette-NPE-tp20652729p20819782.html
> Sent from the Tapestry - User mailing list archive at Nabble.com.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tapestry.apache.org
> For additional commands, e-mail: users-help@tapestry.apache.org
>
>


-- 
James A. Hillyerd <james@hillyerd.com>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message