tapestry-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geoff Longman <glong...@gmail.com>
Subject Re: Slow development cycle
Date Fri, 02 Sep 2005 13:00:24 GMT
Jetty and JettyLauncher (http:jettylauncher.sf.net) (along with tap
cache disabling and the reset service) for me on the desktop makes
debugging a snap. We deploy into Tomcat in all other environments.

Geoff

On 9/2/05, Inge Solvoll <tapestry@ingenett.com> wrote:
> Hi
> 
> I'm running tomcat 5 separately from jboss, and hot deploy of tapestry
> java code from eclipse works just fine for me. Maybe a change to
> tomcat/jboss, instead of just jboss, could work for you?
> 
> I also use MyEclipse with tomcat and jboss running integrated with
> debugging in eclipse.
> 
> Inge
> 
> Leonardo Quijano Vincenzi wrote:
> > Hi again,
> >
> > I have a couple of questions, maybe some of you can help me out. It
> > seems to me that web-app development using Tapestry is getting a bit
> > slow. I had to turn off page-caching, since my changes weren't showing
> > up, and now I end up doing a 10seconds change - compile - redeploy -
> > test cycle.
> >
> > Has anyone one you faced this problem? How do I:
> >
> > 1) Speed up Tapestry initialization:
> >
> > 15:54:11,620 INFO  [org.apache.tapestry.ApplicationServlet] Initialized
> > application servlet 'SigepWeb': 5,658 millis to create HiveMind
> > Registry, 12,278 millis overall.
> >
> > ... 12 seconds, is this normal? My app barely has 6 pages!
> >
> > 2) I guess this could be a non-Tapestry related issue. But maybe someone
> > can help. How do I use hot-deploying on tomcat for Tapestry classes?
> > Everytime I change a page's code I have to restart the whole app (that's
> > 30secs for Spring, 12-15secs for Tapestry - a whole minute on every page
> > change?). Things would be so much better if JBoss didn't throw its
> > hot-deployment errors on me. Any ideas?
> >
> > 3) Develop with the Tapestry cache enabled. I found out I couldn't use
> > tapestry page cache while developing. It doesn't get any changes I make
> > to a page, and I end up rebouncing the app (yep, that's another
> > minute!). Am I doing something wrong?
> >
> > (btw, I'm using MyEclipse 4M3 on a JBoss server. Maybe I could change
> > servers, any recommendations?)
> >
> > Ok, I think that's all. Thanks in advance for any help.
> >
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tapestry-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tapestry-user-help@jakarta.apache.org
> 
> 


-- 
The Spindle guy.           http://spindle.sf.net
Get help with Spindle:   
http://lists.sourceforge.net/mailman/listinfo/spindle-user
Announcement Feed:    
http://www.jroller.com/rss/glongman?catname=/Announcements
Feature Updates:            http://spindle.sf.net/updates

---------------------------------------------------------------------
To unsubscribe, e-mail: tapestry-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tapestry-user-help@jakarta.apache.org


Mime
View raw message