tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Peter Niederwieser (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TAP5-2214) Make tapestry5 java8 compatible
Date Tue, 22 Apr 2014 06:47:15 GMT

    [ https://issues.apache.org/jira/browse/TAP5-2214?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13976458#comment-13976458
] 

Peter Niederwieser commented on TAP5-2214:
------------------------------------------

Perhaps because the build cannot currently be run with `gradlew`? My patch (https://issues.apache.org/jira/browse/TAP5-2323)
fixes this problem.

> Make tapestry5 java8 compatible
> -------------------------------
>
>                 Key: TAP5-2214
>                 URL: https://issues.apache.org/jira/browse/TAP5-2214
>             Project: Tapestry 5
>          Issue Type: Improvement
>          Components: plastic
>    Affects Versions: 5.4
>            Reporter: Joachim Van der Auwera
>            Assignee: Kalle Korhonen
>         Attachments: 0001-use-asm-5.0_BETA-for-java8.patch, 0002-TAP5-2214-use-ASM-5.0_BETA-for-java8-compatibility.patch,
plastic-5.3.7-mint-asm5-java8.jar
>
>
> As it stands Tapestry does not work on java8. This seems to be caused by ASM. Updating
the enclosed asm to 5.0_Bet seems to do the trick.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message