tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bob Harner <bobhar...@gmail.com>
Subject Re: Tapestry 5.3.x and Java 8
Date Sat, 01 Feb 2014 16:16:17 GMT
Lenny,

As for whether ASM will be upgraded in the next version of 5.3, I
don't see why not, if there is any demand for it. All the developer
focus has been on 5.4, of course, so currently there doesn't seem to
be a need for any 5.3.8 release. As always, that can change.

As I understand it, ASM is "baked in" with a modified package name so
that there isn't a risk of class conflicts with any other occurrences
of ASM in users' applications and libraries such as Hibernate. Read
the last sentence at http://asm.ow2.org/doc/faq.html

On Fri, Jan 31, 2014 at 5:42 PM, Lenny Primak <lprimak@hope.nyc.ny.us> wrote:
> I am trying to find out about 5.3 specifically, not 5.4.
> I am sure that 5.4 is going to be upgraded to ASM that's compatible with Java 8 at some
point,
> but our projects are using 5.3, and we don't plan to upgrade to 5.4 for various reasons.
> So, if there are no plans for upgrading 5.3 to the new ASM, we need to think about
> alternate plans ahead of time.
>
> Also, is there a particular reason why ASM is 'baked in' to plastic, as opposed
> to just having a separate maven / gradle dependency on it?
> Seems to be much easier to upgrade if it's a regular dependency rather than jarjar'd.
>
>
> On Jan 31, 2014, at 2:04 PM, Joachim Van der Auwera wrote:
>
>> I am currently using Tapestry 5.4 on Java8 by applying the patch given in https://issues.apache.org/jira/browse/TAP5-2214.
>> I have not (yet) found other issues when using Java8.
>>
>> Personally, I would like to see this patch applied, but I understand that including
a non-release version of ASM is not ideal.
>>
>> Kind regards,
>> Joachim
>>
>> On 01/31/2014 07:44 PM, Lenny Primak wrote:
>>> Is there a plan to update 5.3.x when Java 8 comes out?
>>> Is it just the matter of the version of ASM that is used or is there something
>>> else that precludes 5.3.x to run on Java 8?
>>>
>>> Thanks
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: dev-unsubscribe@tapestry.apache.org
>>> For additional commands, e-mail: dev-help@tapestry.apache.org
>>>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@tapestry.apache.org
>> For additional commands, e-mail: dev-help@tapestry.apache.org
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@tapestry.apache.org
> For additional commands, e-mail: dev-help@tapestry.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tapestry.apache.org
For additional commands, e-mail: dev-help@tapestry.apache.org


Mime
View raw message