tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bob Harner <bobhar...@gmail.com>
Subject Re: Bootstrap 3 and tapestry 5.4
Date Sat, 27 Jul 2013 13:37:22 GMT
<switching this to the dev list>

>From http://blog.getbootstrap.com/ about Bootstrap 3: "With over ~1,600
commits, ~72,000 additions/deletions, and ~300 files changed,everything has
changed." The list of changes: https://github.com/twbs/bootstrap/pull/6342

The Bootstrap version question raises a larger issue... should each version
of Tapestry be tied to a certain version of Bootstrap?

In my experience the biggest part of migrating an app from Tapestry 5.3 to
5.4 is adjusting to the massively changed styles of the built-in Tapestry
components due to the introduction of Bootstrap. Even for apps that already
use Bootstrap, there are CSS adjustments for the particular version of
Bootstrap that Tapestry includes.

I wonder if there is some mechanism that could be introduced that would
allow for the creation of compatibility modes (or compatibility modules)
for the CSS in the built-in components. I have no idea what that mechanism
would look like, but if it existed then it could allow users to choose
between Bootstrap 2 versus 3 versus the old non-Bootstrap styles.

On Sat, Jul 27, 2013 at 8:49 AM, Barry Books <trsvax@gmail.com> wrote:

> I would agree with that.  I suspect Bootstrap 3 will be done before
> Tapestry 5.5 and the markup between Bootstrap 2 and 3 changes.
>
>
> On Sat, Jul 27, 2013 at 3:15 AM, Dimitris Zenios
> <dimitris.zenios@gmail.com>wrote:
>
> > Hi everyone
> >
> > Bootstrap 3 RC1 is released and get bootstrap page redirect to download
> the
> > new version instead of the old (2.3.2)
> >
> >
> > As a suggestion maybe it will be better to upgrade the bundled bootstrap
> > inside tapestry 5.4 to version 3 before a final release
> >
> > Regards
> > Dimitris Zenios
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message