tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Eynon (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TAP5-1880) gzip compression should be disabled if the request is over http 1.0
Date Wed, 21 Mar 2012 04:36:08 GMT

    [ https://issues.apache.org/jira/browse/TAP5-1880?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13234081#comment-13234081
] 

Steve Eynon commented on TAP5-1880:
-----------------------------------

I think we may have run into the same issue last week... does this manifest itself as an intermittant
error?
                
> gzip compression should be disabled if the request is over http 1.0
> -------------------------------------------------------------------
>
>                 Key: TAP5-1880
>                 URL: https://issues.apache.org/jira/browse/TAP5-1880
>             Project: Tapestry 5
>          Issue Type: Improvement
>          Components: tapestry-core
>    Affects Versions: 5.3.2
>            Reporter: Paul Stanton
>              Labels: gzip
>
> Internet explorer when behind a proxy defaults to using HTTP 1.0 (instead of HTTP 1.1)
and in this scenario, GZIP compression is still applied to the response and the clients do
not interpret the response correctly.
> This may either be caused by the client incorrectly setting 'accept-encoding' or incorrectly
reading the 'encoding' headers at either end, however since it only occurs over http 1.0 it
should just be disabled for all http 1.0 requests.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message