tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Igor Drobiazko (JIRA)" <j...@apache.org>
Subject [jira] Assigned: (TAP5-937) LinkImpl does not handle parameters properly when passed into the constructor
Date Mon, 11 Jan 2010 21:00:54 GMT

     [ https://issues.apache.org/jira/browse/TAP5-937?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Igor Drobiazko reassigned TAP5-937:
-----------------------------------

    Assignee: Igor Drobiazko

> LinkImpl does not handle parameters properly when passed into the constructor
> -----------------------------------------------------------------------------
>
>                 Key: TAP5-937
>                 URL: https://issues.apache.org/jira/browse/TAP5-937
>             Project: Tapestry 5
>          Issue Type: Bug
>          Components: tapestry-core
>    Affects Versions: 5.1
>            Reporter: Joost Schouten
>            Assignee: Igor Drobiazko
>             Fix For: 5.2.0
>
>         Attachments: parameter_addition_patch.txt
>
>
> I noticed this after using the AjaxFormLoop AddRowLink on a page which has an onActivate
and onPassivate resulting in the addition of a "t:ac" to the url. Debugging showed me that
the t:ac is already present on instantiation of the LinkImpl. When calling toAbsoluteUri the
parameters are added in a way where they will always start with a "?". Obvisouly resulting
in an invalid URL with two ?'s
> I'm building a failing test at this stage and will provide a patch once resolved.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message