tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Howard M. Lewis Ship (JIRA)" <j...@apache.org>
Subject [jira] Closed: (TAP5-760) The Form event "validateForm" is awkwardly named and should be replaced with the simpler name "validate"
Date Wed, 13 Jan 2010 02:19:54 GMT

     [ https://issues.apache.org/jira/browse/TAP5-760?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Howard M. Lewis Ship closed TAP5-760.
-------------------------------------

       Resolution: Fixed
    Fix Version/s: 5.2.0

> The Form event "validateForm" is awkwardly named and should be replaced with the simpler
name "validate"
> --------------------------------------------------------------------------------------------------------
>
>                 Key: TAP5-760
>                 URL: https://issues.apache.org/jira/browse/TAP5-760
>             Project: Tapestry 5
>          Issue Type: Improvement
>          Components: tapestry-core
>    Affects Versions: 5.1.0.5
>            Reporter: Howard M. Lewis Ship
>            Assignee: Howard M. Lewis Ship
>            Priority: Minor
>             Fix For: 5.2.0
>
>
> You end up with methods like onValidateFormFromLogin() which is just asking for trouble.
> onFormValidateFromLogin() is a bit better.
> Obviously, we keep the old name as well ... have to fire two events at the validate form
stage.
> What would be a better name?  Something that doesn't have "form" is it; perhaps "finalValidation"
or just "validate". I remember this was a problem with calling it "validate" before, because
this conflicted with the validate event form form control element components ... but is that
really a problem?

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message