tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ville Virtanen (JIRA)" <j...@apache.org>
Subject [jira] Updated: (TAP5-871) Generation of Component Reference failed on Windows
Date Mon, 23 Nov 2009 14:41:39 GMT

     [ https://issues.apache.org/jira/browse/TAP5-871?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ville Virtanen updated TAP5-871:
--------------------------------

    Attachment: component_report_patch.patch
                component_report.zip

Just ran in to this problem and got too frustrated, so I just rolled my own.. Attached is
zip that contains corrected version of tapestry-component-report. You can copy it to your
.m2 directory to the correct location and then you are on your way.

Ugly solution was to replace 

builder.append(path); 
to
if(SystemUtils.IS_OS_WINDOWS) {
    builder.append(path.replace("\\", "/"));
} else {
    builder.append(path);
}

in line 839 in ComponentReport.java. This results corrected component-report-javadoc-arguments.txt
file in windows but leaves the generation untouched in other platforms.

Also attached patch that corrects this problem that shouldn't exist at all if maven was coded
correctly?

> Generation of Component Reference failed on Windows
> ---------------------------------------------------
>
>                 Key: TAP5-871
>                 URL: https://issues.apache.org/jira/browse/TAP5-871
>             Project: Tapestry 5
>          Issue Type: Bug
>          Components: tapestry-component-report
>    Affects Versions: 5.1.0.5
>            Reporter: Armin Rauch
>         Attachments: component_report.zip, component_report_patch.patch
>
>
> The maven site generation on my CI machine (which is running Linux) works well while
using the tapestry-component-report plugin. If I try to stage the site on my windows development
machine I encounter the following error during
> mvn site:stage -DstagingDirectory=C:\fullsite
> ......
> [INFO] Cobertura Report generation was successful.
> [INFO] Generating "Component Reference" report.
> [INFO] Running JavaDoc to collect component parameter data ...
> 1 error
> [INFO] ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] Error during page generation
> Embedded error: Error rendering Maven report: Javadoc exit code: 1 - javadoc: error -
Cannot find doclet class org.apache.tapestry.mojo.ParametersDocl
> et
> Command line was: cmd.exe /X /C "c:\Programme\Java\jdk1.5.0_17\jre\..\bin\javadoc.exe
@target/component-report-javadoc-arguments.txt"
> [INFO] ------------------------------------------------------------------------
> [INFO] For more information, run Maven with the -e switch
> I have tried to change all path entrys in the generated file component-report-javadoc-arguments.txt
from '\' to '/' and executed the failing command line manually. Javadoc worked with the modified
file. The generation of said file should be changed to a different path seperator.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message