tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Constantin Partac (JIRA)" <j...@apache.org>
Subject [jira] Commented: (TAP5-541) Regression: Parameter namespacePrefix was null
Date Mon, 27 Jul 2009 20:54:15 GMT

    [ https://issues.apache.org/jira/browse/TAP5-541?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12735769#action_12735769
] 

Constantin Partac commented on TAP5-541:
----------------------------------------

I had the same issue but the cause was not an older version of woodstox but JBoss 4.2.2 (Andrej
was right).

The problem can be by adding the following system properties:
	  javax.xml.stream.XMLInputFactory=com.ctc.wstx.stax.WstxInputFactory
	  javax.xml.stream.XMLOutputFactory=com.ctc.wstx.stax.WstxOutputFactory
	  javax.xml.stream.XMLEventFactory=com.ctc.wstx.stax.WstxEventFactory
	  com.sun.xml.ws.api.streaming.XMLStreamReaderFactory.woodstox=true
	  com.sun.xml.ws.api.streaming.XMLStreamWriterFactory.woodstox=true

and by adding the following jars in lib folder of the JBoss server instace (not WEB-INF/lib
where they are optional now):
	  woodstox-core-asl-4.0.3.jar
	  stax-api-1.0.1.jar
	  stax2-api-3.0.1.jar


> Regression: Parameter namespacePrefix was null
> ----------------------------------------------
>
>                 Key: TAP5-541
>                 URL: https://issues.apache.org/jira/browse/TAP5-541
>             Project: Tapestry 5
>          Issue Type: Bug
>          Components: tapestry-core
>    Affects Versions: 5.1
>         Environment: Windows XP 5.1,x86, Java HotSpot(TM) Client VM 1.5.0_15-b04,Sun
Microsystems Inc., JBoss 4.2.3
>            Reporter: Andrej Aschenbrenner
>            Assignee: Howard M. Lewis Ship
>
> I get an exception after switching to the new Tapestry 5.1.0.0 Version.
> Relevant Template snippet:
> <html xmlns="http://www.w3.org/1999/xhtml"
>       xmlns:t="http://tapestry.apache.org/schema/tapestry_5_0_0.xsd">
> <head>
>     <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
>     <title>${title}</title>
>     <meta name="version" content="${version}" />
>     <link rel="stylesheet" type="text/css" href="${asset:context:css/global.css}"/>
>     <link rel="stylesheet" type="text/css" title="Standard" href="${asset:context:css/standard/style.css}"/>
> </head>
> ...
> Exception StackTrace snippet:
> 16:18:38,581 ERROR [Login] Render queue error in CompositeRenderCommand[Start[http://www.w3.org/1999/xhtml
html], DefineNamespace[null http://www.w3.org/1999/xhtml], Text[
> ], Start[http://www.w3.org/1999/xhtml head], Text[
>     ], Start[http://www.w3.org/1999/xhtml meta], AttributeNS[ http-equiv "Content-Type"],
AttributeNS[ content "text/html; charset=UTF-8"], End, Text[
>     ], Start[http://www.w3.org/1999/xhtml title]]: Parameter namespacePrefix was null.
> java.lang.IllegalArgumentException: Parameter namespacePrefix was null.
> 	at org.apache.tapestry5.ioc.internal.util.Defense.notNull(Defense.java:37)
> 	at org.apache.tapestry5.dom.Element.defineNamespace(Element.java:519)
> 	at org.apache.tapestry5.internal.services.MarkupWriterImpl.defineNamespace(MarkupWriterImpl.java:221)
> 	at org.apache.tapestry5.internal.pageload.PageLoaderImpl$4.render(PageLoaderImpl.java:341)
> 	at org.apache.tapestry5.internal.pageload.CompositeRenderCommand.render(CompositeRenderCommand.java:68)
> 	at org.apache.tapestry5.internal.services.RenderQueueImpl.run(RenderQueueImpl.java:74)
> 	at org.apache.tapestry5.internal.services.PageRenderQueueImpl.render(PageRenderQueueImpl.java:121)
> 	at $PageRenderQueue_11fb85075e4.render($PageRenderQueue_11fb85075e4.java)
> 	at $PageRenderQueue_11fb85075db.render($PageRenderQueue_11fb85075db.java)
> 	at org.apache.tapestry5.internal.services.MarkupRendererTerminator.renderMarkup(MarkupRendererTerminator.java:37)
> ...
> For me it seems that Tapestry requires a namespace declaration on the <title> tag.
But I have already the default namespace declaration on
> the <html xmlns="http://www.w3.org/1999/xhtml"> tag.
> P.S. with only <html xmlns:t="http://tapestry.apache.org/schema/tapestry_5_0_0.xsd">
it fails also. But it did work on Tapestry 5.0.18
> Thanks,
> Andrej Aschenbrenner

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message