tapestry-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian K. Wallace" <br...@transmorphix.com>
Subject Re: Naming question
Date Thu, 24 Feb 2005 22:32:09 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Container sounds logical - but I'd definitely go with
ContainerEntryPoint over ContainerLet.

Howard Lewis Ship wrote:
| I'm starting to introduce the abstraction layer on top of the
| Servlet/Portlet  APIs.  The vast majority of code will be interacting
| with these wrappers, rather than the real objects (actually, the vast
| majority of Tapestry code won't interact with either).
|
| In any case, I'm trying to come up with generic names.  I'm using the
| prefix "Container", as in "provided by the Container".  Here's what
| I've got:
|
|
| HttpServletRequest, ActionRequest, RenderRequest --> ContainerRequest.
| HttpServletResponse, ActionResponse, RenderResponse -> ContainerResponse
| HttpSession, PortletSession -> ContainerSession
| ServletContext, PortletContext -> ContainerContext
| HttpServlet, Portlet -> ContainerLet
|
| I don't like ContainerLet, what's a better name. Possibly
ContainerEntryPoint?
|
| Does "Container" seem logical to anyone/everyone else?
|
| Best time to change it is now, before I get in too deep.
|
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.5 (MingW32)

iD8DBQFCHlXpaCoPKRow/gARAmZTAKDyRXcbAm6UJgsYw1hfQznPFjAaEgCeM9KF
GlbNXf/9BSUDSLbFRWOm7tw=
=NXAX
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: tapestry-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tapestry-dev-help@jakarta.apache.org


Mime
View raw message