tapestry-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From build...@apache.org
Subject svn commit: r932386 - in /websites/production/tapestry/content: 2014/12/11/tapestry-538.html cache/main.pageCache index.html news.html release-notes-538.html
Date Fri, 12 Dec 2014 01:19:35 GMT
Author: buildbot
Date: Fri Dec 12 01:19:34 2014
New Revision: 932386

Log:
Production update by buildbot for tapestry

Modified:
    websites/production/tapestry/content/2014/12/11/tapestry-538.html
    websites/production/tapestry/content/cache/main.pageCache
    websites/production/tapestry/content/index.html
    websites/production/tapestry/content/news.html
    websites/production/tapestry/content/release-notes-538.html

Modified: websites/production/tapestry/content/2014/12/11/tapestry-538.html
==============================================================================
--- websites/production/tapestry/content/2014/12/11/tapestry-538.html (original)
+++ websites/production/tapestry/content/2014/12/11/tapestry-538.html Fri Dec 12 01:19:34
2014
@@ -56,8 +56,8 @@
   </div>
 
 <div id="content">
-<div id="ConfluenceContent"><div class="wiki-content"><p>Apache Tapestry
5.3.8: compatible with Java 8.</p><p>Tapestry is primarily available for download
via Maven, from the Maven central repository:</p><strong>Maven Dependency</strong><div
class="syntaxhighlighter nogutter xml"><div class="code panel pdl" style="border-width:
1px;"><div class="codeContent panelContent pdl">
-<script class="theme: Default; brush: java; gutter: false" type="syntaxhighlighter"><![CDATA[&lt;dependency&gt;

+<div id="ConfluenceContent"><div class="wiki-content"><p>Apache Tapestry
5.3.8: compatible with Java 8.</p><p>Tapestry is primarily available for download
via Maven, from the Maven central repository:</p><p>&#160;</p><div
class="syntaxhighlighter nogutter xml"><div class="code panel pdl" style="border-width:
1px;"><div class="codeHeader panelHeader pdl" style="border-bottom-width: 1px;"><b>Maven
Dependency</b></div><div class="codeContent panelContent pdl">
+<script class="theme: Default; brush: xml; gutter: false" type="syntaxhighlighter"><![CDATA[&lt;dependency&gt;

 &lt;groupId&gt;org.apache.tapestry&lt;/groupId&gt; 
 &lt;artifactId&gt;tapestry-core&lt;/artifactId&gt; 
 &lt;version&gt;5.3.8&lt;/version&gt; 

Modified: websites/production/tapestry/content/cache/main.pageCache
==============================================================================
Binary files - no diff available.

Modified: websites/production/tapestry/content/index.html
==============================================================================
--- websites/production/tapestry/content/index.html (original)
+++ websites/production/tapestry/content/index.html Fri Dec 12 01:19:34 2014
@@ -181,7 +181,7 @@ a.blogHeading {
     <div class="wiki-content">
         Apache Tapestry 5.3.8: compatible with Java 8.
 Tapestry is primarily available for download via Maven, from the Maven central repository:
-Maven Dependency
+&#160;
 &lt;dependency&gt; 
 &lt;groupId&gt;org.apache.tapestry&lt;/groupId&gt; 
 &lt;artifactId&gt;tapestry-core&lt;/artifactId&gt; 

Modified: websites/production/tapestry/content/news.html
==============================================================================
--- websites/production/tapestry/content/news.html (original)
+++ websites/production/tapestry/content/news.html Fri Dec 12 01:19:34 2014
@@ -75,7 +75,7 @@
     <div class="wiki-content">
         Apache Tapestry 5.3.8: compatible with Java 8.
 Tapestry is primarily available for download via Maven, from the Maven central repository:
-Maven Dependency
+&#160;
 &lt;dependency&gt; 
 &lt;groupId&gt;org.apache.tapestry&lt;/groupId&gt; 
 &lt;artifactId&gt;tapestry-core&lt;/artifactId&gt; 

Modified: websites/production/tapestry/content/release-notes-538.html
==============================================================================
--- websites/production/tapestry/content/release-notes-538.html (original)
+++ websites/production/tapestry/content/release-notes-538.html Fri Dec 12 01:19:34 2014
@@ -64,7 +64,7 @@
   </div>
 
 <div id="content">
-<div id="ConfluenceContent"><p>Tapestry 5.3.8 is a drop-in replacement for prior
Tapestry 5.3 releases. To upgrade, just update the dependency in your build configuration
(Maven POM, Gradle build script, etc.) &#8211; or <a shape="rect" href="https://cwiki.apache.org/confluence/display/TAPESTRY/Download">download</a>
the new JAR file -- and the new version will just work. However, please review the <a shape="rect"
href="https://cwiki.apache.org/confluence/display/TAPESTRY/How+to+Upgrade">How to Upgrade</a>
instructions before upgrading.</p><p>This is a bug fix release, mainly meant to
address compatibility with Java 8. The ASM library is updated to a Java 8 compatible version
(5.0), however, if you wish to run this release on JRE 8, you still need to manually specify
a Java 8 compatible version of javassist (such as 3.18.2-GA). With Maven you'd include:</p><div
class="code panel pdl" style="border-width: 1px;"><div class="codeContent panelContent
pdl">
+<div id="ConfluenceContent"><p>Tapestry 5.3.8 is a drop-in replacement for prior
Tapestry 5.3 releases. To upgrade, just update the dependency in your build configuration
(Maven POM, Gradle build script, etc.) &#8211; or&#160;<a shape="rect" href="download.html">Download</a>
the new JAR file -- and the new version will just work. However, please review the&#160;<a
shape="rect" href="how-to-upgrade.html">How to Upgrade</a> instructions before upgrading.</p><p>This
is a bug fix release, mainly meant to address compatibility with Java 8. The ASM library is
updated to a Java 8 compatible version (5.0), however, if you wish to run this release on
JRE 8, you still need to manually specify a Java 8 compatible version of javassist (such as
3.18.2-GA). With Maven you'd include:</p><div class="code panel pdl" style="border-width:
1px;"><div class="codeContent panelContent pdl">
 <script class="theme: Default; brush: java; gutter: false" type="syntaxhighlighter"><![CDATA[&lt;dependency&gt;
   &lt;groupId&gt;org.javassist&lt;/groupId&gt;
   &lt;artifactId&gt;javassist&lt;/artifactId&gt;
@@ -77,7 +77,7 @@
     &lt;groupId&gt;javassist&lt;/groupId&gt;
   &lt;/exclusion&gt;
 &lt;/exclusions&gt;]]></script>
-</div></div><p>where needed.</p><p>As with any Tapestry upgrade,
be sure to change your <a shape="rect" href="https://cwiki.apache.org/confluence/display/TAPESTRY/General+Questions">application's
version number</a>.</p><p>&#160;</p>             
+</div></div><p>where needed.</p><p>As with any Tapestry upgrade,
be sure to change your&#160;<a shape="rect" href="general-questions.html">application's
version number</a>.</p><p>&#160;</p>             
 <h2>        Bugs fixed
 </h2>
 <ul><li>[<a shape="rect" href="https://issues.apache.org/jira/browse/TAP5-311">TAP5-311</a>]
-         NPE in BeanDisplay if used in a form with a default model



Mime
View raw message