tapestry-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bob Harner (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (TAP5-2295) Vulnerability in Tapestry-upload module due to commons-file-upload
Date Mon, 03 Mar 2014 16:13:21 GMT

     [ https://issues.apache.org/jira/browse/TAP5-2295?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Bob Harner updated TAP5-2295:
-----------------------------

    Summary: Vulnerability in Tapestry-upload module due to commons-file-upload  (was: Vulnerability
found in commons-file-upload < 1.3.1)

> Vulnerability in Tapestry-upload module due to commons-file-upload
> ------------------------------------------------------------------
>
>                 Key: TAP5-2295
>                 URL: https://issues.apache.org/jira/browse/TAP5-2295
>             Project: Tapestry 5
>          Issue Type: Dependency upgrade
>          Components: tapestry-upload
>    Affects Versions: 5.3.5, 5.3.6, 5.3.7, 5.4, 5.2.0
>            Reporter: jose luis sanchez
>            Assignee: Bob Harner
>              Labels: bug, commons-file-upload, security, tapestry-upload
>             Fix For: 5.4, 5.3.8
>
>
> Just found that commons-file-upload < 1.3.1 has a bug that can create a DOS attack
.
> For more information, see 
> http://blog.spiderlabs.com/2014/02/cve-2014-0050-exploit-with-boundaries-loops-without-boundaries.html
> I do believe commons-file-upload 1.2.2 it's been used in tapestry-upload since version
5.2 at least, or even older.
> So recommended option is to update dependency to commons-file-upload-1.3.1.jar



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message