tapestry-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kao...@apache.org
Subject git commit: TAP5-2035: Make it easier to choose another slf4j backend -apply patch to depend only on slf4j-api
Date Thu, 17 Jan 2013 20:10:41 GMT
Updated Branches:
  refs/heads/master 1da50f173 -> 09637fa27


TAP5-2035: Make it easier to choose another slf4j backend -apply patch to depend only on slf4j-api


Project: http://git-wip-us.apache.org/repos/asf/tapestry-5/repo
Commit: http://git-wip-us.apache.org/repos/asf/tapestry-5/commit/09637fa2
Tree: http://git-wip-us.apache.org/repos/asf/tapestry-5/tree/09637fa2
Diff: http://git-wip-us.apache.org/repos/asf/tapestry-5/diff/09637fa2

Branch: refs/heads/master
Commit: 09637fa275565f1805d6248ec182ac9e8a9b54f4
Parents: 1da50f1
Author: Kalle Korhonen <kaosko@apache.org>
Authored: Thu Jan 17 12:10:09 2013 -0800
Committer: Kalle Korhonen <kaosko@apache.org>
Committed: Thu Jan 17 12:10:09 2013 -0800

----------------------------------------------------------------------
 build.gradle                                       |    9 +++++----
 quickstart/build.gradle                            |    1 +
 .../filtered/archetype-resources/build.gradle      |    3 +++
 quickstart/filtered/archetype-resources/pom.xml    |   12 +++++++++++-
 tapestry-ioc/build.gradle                          |    6 ++----
 5 files changed, 22 insertions(+), 9 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/tapestry-5/blob/09637fa2/build.gradle
----------------------------------------------------------------------
diff --git a/build.gradle b/build.gradle
old mode 100644
new mode 100755
index fde0a27..13fbbda
--- a/build.gradle
+++ b/build.gradle
@@ -20,7 +20,8 @@ project.ext.versions = [
     servletapi: "2.5",
     spock: "0.7-groovy-2.0",
     hibernate: "4.1.2.Final",
-    groovy: "2.0.5"
+    groovy: "2.0.5",
+    slf4j: "1.7.2"
 ]
 
 // Provided so that the CI server can override the normal version number for nightly builds.
@@ -114,9 +115,7 @@ dependencies {
 
     // From tapestry-ioc:
     binaries "javax.inject:javax.inject:1"
-    binaries "org.slf4j:slf4j-api:1.6.1"
-    binaries "log4j:log4j:1.2.14"
-    binaries "org.slf4j:slf4j-log4j12:1.6.1"
+    binaries "org.slf4j:slf4j-api:${versions.slf4j}"
     binaries "commons-codec:commons-codec:1.5"
     binaries "org.antlr:antlr-runtime:3.3", { transitive = false }
 }
@@ -159,6 +158,8 @@ subprojects {
         groovy "org.codehaus.groovy:groovy-all:${versions.groovy}"
 
         deployerJars "org.apache.maven.wagon:wagon-http-lightweight:1.0-beta-6"
+
+        testRuntime "org.slf4j:slf4j-log4j12:${versions.slf4j}"
     }
 
     test {

http://git-wip-us.apache.org/repos/asf/tapestry-5/blob/09637fa2/quickstart/build.gradle
----------------------------------------------------------------------
diff --git a/quickstart/build.gradle b/quickstart/build.gradle
index 60232a6..5c215d3 100644
--- a/quickstart/build.gradle
+++ b/quickstart/build.gradle
@@ -30,6 +30,7 @@ task processFiltered(type: Copy) {
             servletApiReleaseVersion: versions.servletapi,
             testngReleaseVersion: versions.testng,
             easymockReleaseVersion: versions.easymock,
+            slf4jReleaseVersion: versions.slf4j,
             year: new GregorianCalendar()[Calendar.YEAR].toString()
     ])
 }

http://git-wip-us.apache.org/repos/asf/tapestry-5/blob/09637fa2/quickstart/filtered/archetype-resources/build.gradle
----------------------------------------------------------------------
diff --git a/quickstart/filtered/archetype-resources/build.gradle b/quickstart/filtered/archetype-resources/build.gradle
index 0bb56ae..e50a79f 100644
--- a/quickstart/filtered/archetype-resources/build.gradle
+++ b/quickstart/filtered/archetype-resources/build.gradle
@@ -47,6 +47,9 @@ dependencies {
 
     compile "org.apache.tapestry:tapestry-core:@tapestryReleaseVersion@"
 
+    // Include the Log4j implementation for the SLF4J logging framework
+    runtime "org.slf4j:slf4j-log4j12:@slf4jReleaseVersion@"
+
     // This adds automatic compression of JavaScript and CSS in production mode:
     compile "org.apache.tapestry:tapestry-yuicompressor:@tapestryReleaseVersion@"
 

http://git-wip-us.apache.org/repos/asf/tapestry-5/blob/09637fa2/quickstart/filtered/archetype-resources/pom.xml
----------------------------------------------------------------------
diff --git a/quickstart/filtered/archetype-resources/pom.xml b/quickstart/filtered/archetype-resources/pom.xml
index b60f297..74195e5 100644
--- a/quickstart/filtered/archetype-resources/pom.xml
+++ b/quickstart/filtered/archetype-resources/pom.xml
@@ -8,7 +8,7 @@
     <name>${artifactId} Tapestry 5 Application</name>
     #set( $D = '$' )
     <dependencies>
-        <!-- Too set up an application with a database, change the artifactId below to
+        <!-- To set up an application with a database, change the artifactId below to
              tapestry-hibernate, and add a dependency on your JDBC driver. You'll also
              need to add Hibernate configuration files, such as hibernate.cfg.xml. -->
         <dependency>
@@ -17,6 +17,14 @@
             <version>${D}{tapestry-release-version}</version>
         </dependency>
 
+        <!-- Include the Log4j implementation for the SLF4J logging framework -->
+        <dependency>
+            <groupId>org.slf4j</groupId>
+            <artifactId>slf4j-log4j12</artifactId>
+            <version>${D}{slf4j-release-version}</version>
+        </dependency>
+
+
         <!-- This adds automatic compression of JavaScript and CSS when in production
mode. -->
         <dependency>
             <groupId>org.apache.tapestry</groupId>
@@ -141,5 +149,7 @@ of testing facilities designed for use with TestNG (http://testng.org/),
so it's
         <servlet-api-release-version>@servletApiReleaseVersion@</servlet-api-release-version>
         <testng-release-version>@testngReleaseVersion@</testng-release-version>
         <easymock-release-version>@easymockReleaseVersion@</easymock-release-version>
+        <slf4j-release-version>@slf4jReleaseVersion@</slf4j-release-version>
+
     </properties>
 </project>

http://git-wip-us.apache.org/repos/asf/tapestry-5/blob/09637fa2/tapestry-ioc/build.gradle
----------------------------------------------------------------------
diff --git a/tapestry-ioc/build.gradle b/tapestry-ioc/build.gradle
index b929941..5220683 100644
--- a/tapestry-ioc/build.gradle
+++ b/tapestry-ioc/build.gradle
@@ -12,9 +12,7 @@ dependencies {
 
   compile "javax.inject:javax.inject:1"
 
-  compile "org.slf4j:slf4j-api:1.6.1"
-  compile "log4j:log4j:1.2.14"
-  compile "org.slf4j:slf4j-log4j12:1.6.1"
+  compile "org.slf4j:slf4j-api:${versions.slf4j}"
 
   testCompile "org.spockframework:spock-core:${versions.spock}"
   testCompile "commons-lang:commons-lang:2.6"
@@ -26,4 +24,4 @@ test {
   useJUnit()
   // Override the master build.gradle
   systemProperties.remove("tapestry.service-reloading-enabled")
-}
\ No newline at end of file
+}


Mime
View raw message