tapestry-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "virgil hong (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TAP5-1957) setupRender methods are not always invoked
Date Mon, 25 Jun 2012 01:24:42 GMT

    [ https://issues.apache.org/jira/browse/TAP5-1957?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13400246#comment-13400246
] 

virgil hong commented on TAP5-1957:
-----------------------------------

yes, it's OK, thanks!
                
> setupRender methods are not always invoked
> ------------------------------------------
>
>                 Key: TAP5-1957
>                 URL: https://issues.apache.org/jira/browse/TAP5-1957
>             Project: Tapestry 5
>          Issue Type: Bug
>          Components: tapestry-core
>    Affects Versions: 5.3.2
>            Reporter: virgil hong
>
> When  after upgrade to 5.3.2, my project some pages not alwarys trigger the SetupRender
method, but after restart the Jetty, then it's OK, it's not stable, or sometime unlucky restart
the server repeat, it's also exists the problem, I have to change the setupRender method to
onAcitvate;
> the strange thing is some pages ok, some pages bad....
> OK, Tks Howard reply, I check my code found the question because of overwrite @ImportWork,
for I can get the exteral resource without localized;
> The Overide method like this:
>  private Asset[] convertPathsToAssetArray(final Resource baseResource, final Locale locale,
String[] assetPaths)
>     {
>         return F.flow(assetPaths).map(new Mapper<String, Asset>()
>         {
>             public Asset map(String assetPath)
>             {
>             	if (assetPath.indexOf(":")>0) {
>             		return assetSource.getUnlocalizedAsset(symbolSource.expandSymbols(assetPath));
>             		//return assetSource.getExpandedAsset(assetPath);
> 				}
>                 return assetSource.getAsset(baseResource, assetPath, locale);
>             }
>         }).toArray(Asset.class);
>     }
> ======================
> so, I guess is setupRender some thing not correct perform after the @Import work

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message