tapestry-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Zeigler (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TAP5-1925) Rename t:remove to t:annotation
Date Sun, 06 May 2012 05:50:41 GMT

    [ https://issues.apache.org/jira/browse/TAP5-1925?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13269132#comment-13269132

Robert Zeigler commented on TAP5-1925:

Your proposed renaming assumes that the only use for <t:remove> is to annotate some
piece of the template. Although that is certainly one potential use of <t:remove>, it's
not the only use. I'm -1 on a rename to "annotation". It's confusing, overloaded, and less
general than "remove". I've never found "remove" unintuitive:

 A bunch of stuff to remove from the template

Seems pretty obvious. 
> Rename t:remove to t:annotation
> -------------------------------
>                 Key: TAP5-1925
>                 URL: https://issues.apache.org/jira/browse/TAP5-1925
>             Project: Tapestry 5
>          Issue Type: Improvement
>          Components: tapestry-core
>    Affects Versions: 5.3.3
>            Reporter: Carsten Klein
>            Priority: Minor
> I am quite unhappy with the naming of the component used for server side comments/annotations
attached to a template.
> t:remove seems a bit awkward, albeit it does reflect on what the template engine actually
> I would recommend deprecating t:remove and introduce a t:annotation component in its

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message