tapestry-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christophe Cordenier (JIRA)" <j...@apache.org>
Subject [jira] Updated: (TAP5-871) Generation of Component Reference failed on Windows
Date Fri, 30 Apr 2010 13:51:00 GMT

     [ https://issues.apache.org/jira/browse/TAP5-871?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Christophe Cordenier updated TAP5-871:

    Attachment: TAP5-871.patch

What about calling a Java escape before append


Work on windows, i guess this will have no effect on Unix...

Patch attached.

> Generation of Component Reference failed on Windows
> ---------------------------------------------------
>                 Key: TAP5-871
>                 URL: https://issues.apache.org/jira/browse/TAP5-871
>             Project: Tapestry 5
>          Issue Type: Bug
>          Components: tapestry-component-report
>    Affects Versions:
>            Reporter: Armin Rauch
>         Attachments: component_report.zip, component_report_patch.patch, TAP5-871.patch
> The maven site generation on my CI machine (which is running Linux) works well while
using the tapestry-component-report plugin. If I try to stage the site on my windows development
machine I encounter the following error during
> mvn site:stage -DstagingDirectory=C:\fullsite
> ......
> [INFO] Cobertura Report generation was successful.
> [INFO] Generating "Component Reference" report.
> [INFO] Running JavaDoc to collect component parameter data ...
> 1 error
> [INFO] ------------------------------------------------------------------------
> [INFO] ------------------------------------------------------------------------
> [INFO] Error during page generation
> Embedded error: Error rendering Maven report: Javadoc exit code: 1 - javadoc: error -
Cannot find doclet class org.apache.tapestry.mojo.ParametersDocl
> et
> Command line was: cmd.exe /X /C "c:\Programme\Java\jdk1.5.0_17\jre\..\bin\javadoc.exe
> [INFO] ------------------------------------------------------------------------
> [INFO] For more information, run Maven with the -e switch
> I have tried to change all path entrys in the generated file component-report-javadoc-arguments.txt
from '\' to '/' and executed the failing command line manually. Javadoc worked with the modified
file. The generation of said file should be changed to a different path seperator.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message