tapestry-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joost Schouten (JIRA)" <j...@apache.org>
Subject [jira] Created: (TAP5-1047) extending Autocomplete no longer works
Date Sat, 06 Mar 2010 03:35:27 GMT
extending Autocomplete no longer works
--------------------------------------

                 Key: TAP5-1047
                 URL: https://issues.apache.org/jira/browse/TAP5-1047
             Project: Tapestry 5
          Issue Type: Bug
          Components: tapestry-core
    Affects Versions: 5.2.0
            Reporter: Joost Schouten


Since february 20th 2 problems have been introduced when extending the Autocomplete mixin.

- The mixin will try to load the autocomplete.js from the classpath location of the extending
class, in stead of the Autocomplete.class
- The @Override methods (eg. generateResponseMarkup(MarkupWriter writer, List matches)) are
no longer called on the extending class

I have been using my extended version for about 18 months without problems and suspect it
might have something to do with the move away from javassist.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message