tapestry-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Howard M. Lewis Ship (JIRA)" <j...@apache.org>
Subject [jira] Created: (TAP5-760) The Form event "validateForm" is awkward, a new name (perhaps "formValidate") would be nice
Date Tue, 30 Jun 2009 18:16:47 GMT
The Form event "validateForm" is awkward, a new name (perhaps "formValidate") would be nice

                 Key: TAP5-760
                 URL: https://issues.apache.org/jira/browse/TAP5-760
             Project: Tapestry 5
          Issue Type: Improvement
          Components: tapestry-core
    Affects Versions:
            Reporter: Howard M. Lewis Ship
            Priority: Minor

You end up with methods like onValidateFormFromLogin() which is just asking for trouble.

onFormValidateFromLogin() is a bit better.

Obviously, we keep the old name as well ... have to fire two events at the validate form stage.

What would be a better name?  Something that doesn't have "form" is it; perhaps "finalValidation"
or just "validate". I remember this was a problem with calling it "validate" before, because
this conflicted with the validate event form form control element components ... but is that
really a problem?

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message