tamaya-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William Lieurance (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (TAMAYA-410) Update camel-core dependency past CVE-2019-0188
Date Fri, 07 Jun 2019 05:04:00 GMT

     [ https://issues.apache.org/jira/browse/TAMAYA-410?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

William Lieurance closed TAMAYA-410.
------------------------------------
    Resolution: Fixed

> Update camel-core dependency past CVE-2019-0188
> -----------------------------------------------
>
>                 Key: TAMAYA-410
>                 URL: https://issues.apache.org/jira/browse/TAMAYA-410
>             Project: Tamaya
>          Issue Type: Improvement
>            Reporter: William Lieurance
>            Assignee: William Lieurance
>            Priority: Minor
>          Time Spent: 20m
>  Remaining Estimate: 0h
>
> h5. CVE-2019-0188
>  
> high severity
> *Vulnerable versions:* < 2.24.0
> *Patched version:* 2.24.0
> Apache Camel prior to 2.24.0 contains an XML external entity injection (XXE) vulnerability
(CWE-611) due to using an outdated vulnerable JSON-lib library. This affects only the camel-xmljson
component, which was removed.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message