tajo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emin TÜYLÜCE <etuyl...@gmail.com>
Subject Re: Tajo Rest Api
Date Sun, 18 Oct 2015 12:08:52 GMT
Thanks Jihoon , How I should send session Id ?  Could you give me an
example  please ?  Because in the documentation  that part is not clear .

Thanks ,

Emin

On Sun, Oct 18, 2015 at 2:18 AM, Jihoon Son <ghoonson@gmail.com> wrote:

> This message also means that your session id is missed.
> It seems that our error message is very unkind to users. I opened a jira
> ticket to improve it (https://issues.apache.org/jira/browse/TAJO-1937).
>
> Thanks!
> Jihoon
>
> 2015년 10월 18일 (일) 오전 3:25, Emin TÜYLÜCE <etuyluce@gmail.com>님이
작성:
>
>> Hi Jihoon / Char  thank you very much now I am getting similar
>> querydetails  . Now I want to  get query result dataset,
>> { ..... "bytesNum": 0, "resultset": { "id": 7754785746404232000, "link":
>> "
>> http://192.168.0.120:26880/rest/queries/q_1445080186694_0004/result/7754785746404232624
>> " } }
>>
>> First When I use  link in json result  with curl I am getting
>> "curl
>> http://192.168.0.120:26880/rest/queries/q_1445080186694_0004/result/7754785746404232624
>>
>> MessageBodyWriter not found for media type=application/octet-stream,
>> type=class org.apache.tajo.ws.rs.responses.ExceptionResponse,
>> genericType=class org.apache.tajo.ws.rs.responses.ExceptionResponse."
>>
>> Whats is the best way to get result dataset
>>
>> Thanks
>>
>> Emin
>>
>>
>>
>> On Sat, Oct 17, 2015 at 5:11 PM, CharSyam <charsyam@gmail.com> wrote:
>>
>>> Tajo Rest Api needs X-Tajo-Session header.
>>> Currently, If session header doesn't exis, It will return NPE.
>>> I will soon change error type from internal error to bad request.
>>> Thanks.
>>>
>>> 2015-10-18 0:42 GMT+09:00 Jihoon Son <ghoonson@gmail.com>:
>>>
>>>> Emin, this problem is due to the missing session id in the request
>>>> header.
>>>> You need to explicitly add a session id for Tajo to your http request
>>>> header like below.
>>>>
>>>> $ curl --header "X-Tajo-Session: 2d6f80f2-8189-4c0f-8f23-578f4fa52096"
>>>> http://localhost:26880/rest/queries/q_1445094169341_0001/result
>>>>
>>>> {"resultCode":"OK","schema":{"fields":[{"name":"?count","typeDesc":{"dataType":{"type":"INT8"}}}],"fieldsByQualifiedName":{"?count":0},"fieldsByName":{"?count":[0]}},"bytesNum":0,"resultset":{"id":3713217288559068505,"link":"
>>>> http://localhost:26880/rest/queries/q_1445091590251_0001/result/3713217288559068505
>>>> "}}
>>>>
>>>> You can create a session using a REST api. Would you test again with a
>>>> session id?
>>>>
>>>> Thanks,
>>>> Jihoon
>>>>
>>>> 2015년 10월 17일 (토) 오후 11:48, Jihoon Son <ghoonson@gmail.com>님이
작성:
>>>>
>>>>> Hi Emin, thanks for reporting. This is definitely our bug.
>>>>> I created a Jira ticket to fix this problem (
>>>>> https://issues.apache.org/jira/browse/TAJO-1936).
>>>>>
>>>>> Thanks!
>>>>> Jihoon
>>>>>
>>>>> 2015년 10월 17일 (토) 오후 8:52, Emin TÜYLÜCE <etuyluce@gmail.com>님이
작성:
>>>>>
>>>>>> Hi Jihoon ,
>>>>>>
>>>>>> .
>>>>>> When i call  any of my executed quries with query id to access
>>>>>> results     I am getting  500, Internal Server Error
>>>>>> This is my url
>>>>>> http://192.168.0.120:26880/rest/queries/q_1445080186694_0001/result
>>>>>> my reference document is
>>>>>> https://issues.apache.org/jira/secure/attachment/12698879/TajoClientRestAPIDesign_v0.1.pdf
>>>>>>
>>>>>>
>>>>>> Thanks  ,
>>>>>>
>>>>>> Emin
>>>>>>
>>>>>>
>>>>>>
>>>>>> On Wed, Oct 14, 2015 at 1:59 AM, Jihoon Son <ghoonson@gmail.com>
>>>>>> wrote:
>>>>>>
>>>>>>> Since we moved to java 8 from 0.12.0, it is strange that 0.11.1
>>>>>>> doesn't work well with java 7.
>>>>>>> I'll investigate it.
>>>>>>> Thanks!
>>>>>>> 2015년 10월 14일 (수) 오전 6:41, Emin TÜYLÜCE <etuyluce@gmail.com>님이
작성:
>>>>>>>
>>>>>>>> After Upgrade Java 8 everything works fine .
>>>>>>>>
>>>>>>>> Thanks .
>>>>>>>> Emin
>>>>>>>>
>>>>>>>> On Tue, Oct 13, 2015 at 8:15 PM, Emin TÜYLÜCE <etuyluce@gmail.com>
>>>>>>>> wrote:
>>>>>>>>
>>>>>>>>> Hi  , I extract "tajo-0.11.1-SNAPSHOT.tar.gz" and I copied
hadoop
>>>>>>>>> folders from my previous extract . when i  run Tajo 
i am getting error
>>>>>>>>> message in web frontend of Tajo.
>>>>>>>>>
>>>>>>>>> "HTTP ERROR: 500
>>>>>>>>>
>>>>>>>>> PWC6033: Unable to compile class for JSP
>>>>>>>>>
>>>>>>>>> RequestURI=/
>>>>>>>>> Caused by:
>>>>>>>>>
>>>>>>>>> org.apache.jasper.JasperException: PWC6033: Unable to
compile
>>>>>>>>> class for JSP
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> at
>>>>>>>>> org.apache.jasper.compiler.DefaultErrorHandler.javacError(DefaultErrorHandler.java:123)
>>>>>>>>> at
>>>>>>>>> org.apache.jasper.compiler.ErrorDispatcher.javacError(ErrorDispatcher.java:296)
>>>>>>>>> at
>>>>>>>>> org.apache.jasper.compiler.Compiler.generateClass(Compiler.java:376)
>>>>>>>>> at org.apache.jasper.compiler.Compiler.compile(Compiler.java:437)
>>>>>>>>> at
>>>>>>>>> org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:608)"
>>>>>>>>>
>>>>>>>>> error message .
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> Thanks ,
>>>>>>>>>
>>>>>>>>> Emin
>>>>>>>>>
>>>>>>>>> On Sat, Oct 10, 2015 at 3:06 PM, Emin TÜYLÜCE <etuyluce@gmail.com>
>>>>>>>>> wrote:
>>>>>>>>>
>>>>>>>>>> Hi , I used standalone desktop package of Tajo ,
I will try
>>>>>>>>>> nightly build.
>>>>>>>>>>
>>>>>>>>>> Thanks,
>>>>>>>>>>
>>>>>>>>>> Emin
>>>>>>>>>>
>>>>>>>>>> On Sat, Oct 10, 2015 at 2:34 PM, Jihoon Son <ghoonson@gmail.com>
>>>>>>>>>> wrote:
>>>>>>>>>>
>>>>>>>>>>> Seems strange. I also tested getting query list
using rest
>>>>>>>>>>> client, and found it works well with my laptop.
>>>>>>>>>>> When did you build your snapshot version? Would
you try the
>>>>>>>>>>> nightly build version (
>>>>>>>>>>> https://builds.apache.org/view/All/job/Tajo-0.11.0-nightly/lastSuccessfulBuild/artifact/tajo-dist/target/tajo-0.11.1-SNAPSHOT.tar.gz
>>>>>>>>>>> )?
>>>>>>>>>>>
>>>>>>>>>>> In addition, please check if the session is expired.
You can see
>>>>>>>>>>> in Tajo master's log. The default log path is
${TAJO_HOME}/logs/tajo-${
>>>>>>>>>>> user.name}-master-xxx.log.
>>>>>>>>>>>
>>>>>>>>>>> Best regards,
>>>>>>>>>>> Jihoon
>>>>>>>>>>>
>>>>>>>>>>> 2015년 10월 10일 (토) 오후 9:32, Emin TÜYLÜCE
<etuyluce@gmail.com>님이
>>>>>>>>>>> 작성:
>>>>>>>>>>>
>>>>>>>>>>>> Hi  ,
>>>>>>>>>>>>
>>>>>>>>>>>> I am using Tajo 0.11.0-SNAPSHOT  . I wanted
to use Tajo rest
>>>>>>>>>>>> api . In my try Databases rest functions
are working very  well but when I
>>>>>>>>>>>> try query related functions (Get Post ) in
rest client I am getting 404
>>>>>>>>>>>> messages .
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> This is my Url  :  http://192.168.0.120:26880/rest/queries
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> Thanks ,
>>>>>>>>>>>>
>>>>>>>>>>>> Emin
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>
>>>>>>>>
>>>>>>
>>>
>>

Mime
View raw message