tajo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jinho Kim <jh...@apache.org>
Subject Fwd: Reg: Apache Tajo Installation
Date Tue, 15 Sep 2015 16:57:22 GMT
my mistake to sends
fiy

-Jinho
Best regards

2015-09-16 1:49 GMT+09:00 Jinho Kim <jhkim@apache.org>:

> Thanks for your feedback
>
> I recommend that you send to tajo-dev for your problems. because probably
> other guy have your same problems.
> please let us know for fix your problems
>
> -Jinho
> Best regards
>
> 2015-09-15 15:38 GMT+09:00 kumar sai <kumar.sai020985@gmail.com>:
>
>> Hi Jinho Kim,
>> I have
>> deployed hadoop-common-2.1.0-beta.jar,hadoop-yarn-common-0.23.5.jar these
>> to files in lib folder and i started the server.
>> This time i am getting bellow error.
>> r
>> STARTUP_MSG:   build = git@github.com:hyunsik/tajo.git -r
>> c94edd86a17cf9e26ffb58787a8f7dcf13cfbf43; compiled by 'hyunsik' on
>> 2015-06-24T04:07Z
>> STARTUP_MSG:   java = 1.7.0_55
>> ************************************************************/
>> Sep 15, 2015 2:16:36 PM org.apache.hadoop.util.SignalLogger register
>> INFO: registered UNIX signal handlers for [TERM, HUP, INT]
>> Sep 15, 2015 2:16:36 PM org.apache.tajo.worker.TajoWorker main
>> SEVERE: Error starting TajoWorker
>> java.lang.NoSuchMethodError:
>> org.apache.tajo.worker.TajoWorker.addIfService(Ljava/lang/Object;)Z
>>         at
>> org.apache.tajo.worker.TajoWorker.serviceInit(TajoWorker.java:221)
>>         at
>> org.apache.hadoop.service.AbstractService.init(AbstractService.java:163)
>>         at
>> org.apache.tajo.worker.TajoWorker.startWorker(TajoWorker.java:156)
>>         at org.apache.tajo.worker.TajoWorker.main(TajoWorker.java:697)
>>
>> Sep 15, 2015 2:16:36 PM org.apache.tajo.util.StringUtils$1 run
>> INFO: SHUTDOWN_MSG:
>> /************************************************************
>> SHUTDOWN_MSG: Shutting down TajoWorker at h1.hadoop.com/192.168.152.141
>> ************************************************************/
>> Exception in thread "Thread-3" java.lang.ExceptionInInitializerError
>>         at
>> org.apache.tajo.worker.TajoWorker$ShutdownHook.run(TajoWorker.java:609)
>>         at java.lang.Thread.run(Thread.java:745)
>> Caused by: java.lang.IllegalStateException: Shutdown in progress
>>         at
>> java.lang.ApplicationShutdownHooks.add(ApplicationShutdownHooks.java:66)
>>         at java.lang.Runtime.addShutdownHook(Runtime.java:211)
>>         at
>> org.apache.tajo.rpc.RpcChannelFactory.<clinit>(RpcChannelFactory.java:59)
>>         ... 2 more
>>
>>
>>
>> Could you please help me where i am doing mistake.
>>
>>
>>
>> On Tue, Sep 15, 2015 at 10:05 AM, kumar sai <kumar.sai020985@gmail.com>
>> wrote:
>>
>>> Thank you so much for your reply Mr Jinho Kim.
>>> While I am starting Tajo, its throwing below error.
>>>
>>> java.lang.ClassNotFoundException:
>>> org.apache.hadoop.service.CompositeService
>>>         at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
>>>         at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
>>>         at java.security.AccessController.doPrivileged(Native Method)
>>>
>>>
>>>
>>> please find rootdir location. where i have created tajo directory in
>>> CDH5.1.
>>>
>>>  <property>
>>>   <name>tajo.rootdir</name>
>>>   <value>hdfs://192.168.152.141:8020/tajo</value>
>>>   <description>Base directory including system directories.</description>
>>> </property>
>>>
>>> <property>
>>>   <name>tajo.master.umbilical-rpc.address</name>
>>>   <value>192.168.152.141:26001</value>
>>>   <description>TajoMaster binding address between master and
>>> workers.</description>
>>> </property>
>>>
>>>
>>> On Mon, Sep 14, 2015 at 8:06 PM, Jinho Kim <jhkim@apache.org> wrote:
>>>
>>>> Dear Saikumar
>>>>
>>>> Unfortunately, tajo does not support hadoop-0.21.0. please see
>>>> following link
>>>> http://tajo.apache.org/docs/current/getting_started.html#prerequisites
>>>> Do you have a reason for deploying hadoop-0.21.0 ?
>>>>
>>>> Thanks
>>>>
>>>> -Jinho
>>>> Best regards
>>>>
>>>> 2015-09-14 19:10 GMT+09:00 kumar sai <kumar.sai020985@gmail.com>:
>>>>
>>>>> Dear jhkim,
>>>>> I am saikumar. I need some favor in setting up Apache Tajo cluster on
>>>>> Cloudera hadoop environment.
>>>>>
>>>>> Could you please help me I am facing below issue.
>>>>> I have deployed hadoop-common-0.21.0.jar. even though i am facing the
>>>>> same issue. Its not able to identify jar.
>>>>> Could you please help to resolve this issue.
>>>>>
>>>>> [root@h1 bin]# tail -200
>>>>> /opt/tajo-0.10.1/bin/../logs/tajo-root-worker-h1.hadoop.com.out
>>>>> Exception in thread "main" java.lang.NoClassDefFoundError:
>>>>> org/apache/hadoop/service/CompositeService
>>>>>         at java.lang.ClassLoader.defineClass1(Native Method)
>>>>>         at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
>>>>>         at
>>>>> java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
>>>>>         at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)
>>>>>         at java.net.URLClassLoader.access$100(URLClassLoader.java:71)
>>>>>         at java.net.URLClassLoader$1.run(URLClassLoader.java:361)
>>>>>         at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
>>>>>         at java.security.AccessController.doPrivileged(Native Method)
>>>>>         at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
>>>>>         at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
>>>>>         at
>>>>> sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
>>>>>         at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
>>>>>         at
>>>>> sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:482)
>>>>> Caused by: java.lang.ClassNotFoundException:
>>>>> org.apache.hadoop.service.CompositeService
>>>>>         at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
>>>>>
>>>>>
>>>>> Thank you so much.
>>>>>
>>>>> Regards,
>>>>> Saikumar.
>>>>>
>>>>
>>>>
>>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message