tajo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jihoon Son <jihoon...@apache.org>
Subject The unit tests never stop in my mac
Date Thu, 02 Oct 2014 08:07:43 GMT
Hi guys,

as the title, I faced a minor problem.
All tests have passed successfully in my Linux desktop, but, in my laptop,
one of the tests is hanged, and never finished.
The last log is as follows.

2014-10-02 16:36:42,999 INFO: org.apache.tajo.worker.TaskRunner (run(211))
> - Request GetTask: eb_1412235160444_0055_000001,
> container_1412235160444_0055_01_000191
>
> 2014-10-02 16:36:43,002 INFO: org.apache.tajo.worker.TaskRunner (run(249))
> - Received ShouldDie flag:eb_1412235160444_0055_000001,
> container_1412235160444_0055_01_000191
>
> 2014-10-02 16:36:43,002 INFO: org.apache.tajo.worker.TaskRunner (stop(151))
> - Stop TaskRunner: eb_1412235160444_0055_000001,
> container_1412235160444_0055_01_000191
>
> 2014-10-02 16:36:43,002 INFO: org.apache.tajo.worker.TaskRunnerManager (
> stopTaskRunner(116)) - Stop Task:eb_1412235160444_0055_000001,
> container_1412235160444_0055_01_000191
>
> 2014-10-02 16:36:43,002 INFO: org.apache.tajo.master.TajoAsyncDispatcher (
> start(101)) - AsyncDispatcher started:q_1412235160444_0055
>
> 2014-10-02 16:36:44,076 INFO: org.apache.tajo.master.querymaster.QueryInProgress
> (heartbeat(265)) - Received QueryMaster heartbeat:q_1412235160444_0055,
> state=QUERY_RUNNING,progress=0.0, queryMaster=10.16.19.176
>
> 2014-10-02 16:36:46,078 INFO: org.apache.tajo.master.querymaster.QueryInProgress
> (heartbeat(265)) - Received QueryMaster heartbeat:q_1412235160444_0055,
> state=QUERY_RUNNING,progress=0.0, queryMaster=10.16.19.176
>
> 2014-10-02 16:36:48,078 INFO: org.apache.tajo.master.querymaster.QueryInProgress
> (heartbeat(265)) - Received QueryMaster heartbeat:q_1412235160444_0055,
> state=QUERY_RUNNING,progress=0.0, queryMaster=10.16.19.176
>
According to the last log, it seems that a query cannot progress.
I suspect the insufficient memory, but I couldn't find any other clues.
Do you have any idea for this problem?

Here are some test environments.
- Source: master branch
- RAM: 8GB
- OS X Mavericks (10.9.5)
- Maven 3.1.1
- Java 1.6.0_65

Thanks,
Jihoon

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message