tajo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thanh Mai <maihaith...@gmail.com>
Subject Re: Tajo Version On CLI
Date Mon, 07 Jul 2014 05:45:21 GMT
Hi Hyunsik Choi,

Thank you for your instruction. I have not committed the modified files yet
(those files are still in the list "changes to be committed" when I try
"git status").
However, I have just tried "git diff master ..." (instead of only "git diff
...") and a non-empty patch has been created. This one seems to be OK.
So, I uploaded this patch file to JIRA page for TAJO-912. Please review it
and tell me your opinion.

Sincerely yours,

Mai Hai Thanh



On Mon, Jul 7, 2014 at 2:22 PM, Hyunsik Choi <hyunsik@apache.org> wrote:

> Hi Thanh Mai,
>
> Above all, thank you for your participation and interest in Tajo.
>
> If you already commit your change to your local git repo, you cannot
> get the difference from just 'git diff'. You should use 'git diff'
> against a specified branch as follows:
>
> git diff origin/master --no-prefix > TAJO-912.patch
>
> If you have more question, feel free to ask us anything.
>
> Best regards,
> Hyunsik
>
>
> On Mon, Jul 7, 2014 at 2:11 PM, Thanh Mai <maihaithanh@gmail.com> wrote:
> > Hi everyone,
> >
> > I am a newbie to Apache Tajo as well as GIT and open source project
> > development.
> >
> > I start my participation here with a patch to fix the TAJO-912 trivial
> CLI
> > bug.
> >
> > However, after I modify the source code in 2 files, compile and test
> > successfully, and following the instructions to create a patch (below),
> the
> > patch file contains nothing (0 byte).
> >
> > -----------------------------------------------------
> > git status
> >
> > git add src/../file1.java
> > git add src/../file2.java
> >
> > git diff --no-prefix > TAJO-912.patch
> > -----------------------------------------------------
> >
> > (of course, with the real & correct paths to .java files)
> >
> > Can anyone tell me why ?
> >
> > Thank you,
> >
> > Mai Hai Thanh
> >
> >
> >
> > On Mon, Jul 7, 2014 at 10:54 AM, Jaehwa Jung <blrunner@apache.org>
> wrote:
> >
> >> Hello Shrikant,
> >>
> >> I appreciate your interest and bug report.
> >>
> >> I've just created a jira issue as follows:
> >> https://issues.apache.org/jira/browse/TAJO-912
> >>
> >>
> >> Regards
> >> Jaehwa
> >>
> >>
> >>
> >> 2014-07-07 4:51 GMT+09:00 Shrikant Bang <shrikant_bang@outlook.com>:
> >>
> >> > Hello Tajo Devs,
> >> > I am newbie to Apache Tajo.  I have built Tajo from src code checked
> out
> >> > from github.
> >> > The current version of Tajo in trunk is 0.9, however the Tajo CLI
> shows
> >> > version as 0.8.
> >> > default> \version0.8.0-SNAPSHOT
> >> > It looks like a trivial bug.
> >> > Thanks,Shrikant B.
> >> >
> >>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message