tajo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Min Zhou <coderp...@gmail.com>
Subject Re: Development environment for Tajo
Date Sat, 24 May 2014 04:22:50 GMT
oh...  You need to run mvn install before that.



Regards,
Min




On Fri, May 23, 2014 at 9:18 PM, Prafulla <prafullat@yahoo.com> wrote:

> Thanks Min, Let me try IDEA.
>
> For mvn eclipse:eclipse, It fails with following
> Not sure if it something specic to Tajo. Can someone help fix it?
>
>
>
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Building Tajo Common 0.9.0-SNAPSHOT
> [INFO]
> ------------------------------------------------------------------------
> [WARNING] Failed to retrieve plugin descriptor for
> org.apache.tajo:tajo-maven-plugins:0.9.0-SNAPSHOT: Plugin
> org.apache.tajo:tajo-maven-plugins:0.9.0-SNAPSHOT or one of its
> dependencies could not be resolved: Could not find artifact
> org.apache.tajo:tajo-maven-plugins:jar:0.9.0-SNAPSHOT
> [WARNING] The POM for org.eclipse.m2e:lifecycle-mapping:jar:1.0.0 is
> missing, no dependency information available
> [WARNING] Failed to retrieve plugin descriptor for
> org.eclipse.m2e:lifecycle-mapping:1.0.0: Plugin
> org.eclipse.m2e:lifecycle-mapping:1.0.0 or one of its dependencies could
> not be resolved: Failure to find
> org.eclipse.m2e:lifecycle-mapping:jar:1.0.0 in
> http://repo.maven.apache.org/maven2 was cached in the local repository,
> resolution will not be reattempted until the update interval of central has
> elapsed or updates are forced
> [WARNING] Failed to retrieve plugin descriptor for
> org.apache.tajo:tajo-maven-plugins:0.9.0-SNAPSHOT: Plugin
> org.apache.tajo:tajo-maven-plugins:0.9.0-SNAPSHOT or one of its
> dependencies could not be resolved: Could not find artifact
> org.apache.tajo:tajo-maven-plugins:jar:0.9.0-SNAPSHOT
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Reactor Summary:
> [INFO]
> [INFO] Tajo Main ......................................... SUCCESS [6.303s]
> [INFO] Tajo Project POM .................................. SUCCESS [3.031s]
> [INFO] Tajo Maven Plugins ................................ SUCCESS
> [11.034s]
> [INFO] Tajo Common ....................................... FAILURE [0.135s]
> [INFO] Tajo Algebra ...................................... SKIPPED
> [INFO] Tajo Catalog Common ............................... SKIPPED
> [INFO] Tajo Rpc .......................................... SKIPPED
> [INFO] Tajo Catalog Client ............................... SKIPPED
> [INFO] Tajo Catalog Server ............................... SKIPPED
>
>
>
>
>
> On Friday, 23 May 2014 9:12 PM, Min Zhou <coderplay@gmail.com> wrote:
>
>
>
> I am using IDEA, have no issues on the IDE. I think you can just run mvn
> eclipse:eclipse to generate eclipse files and import the project in
> eclipse. That should works.
>
> Best,
> Min
>
>
>
> On Fri, May 23, 2014 at 9:08 PM, Prafulla <prafullat@yahoo.com> wrote:
>
> Hi,
> >
> >Could some Tajo contributor share their development environment? I am
> especially looking for tools (IDE etc) that you use while writing
> code/fixing issues.
> >I tried to configure eclipse to work with Tajo, but I could not get it to
> work.
> >
> >
> >PS: I can already build/run tests of tajo from command line.
> >
> >--
> >Thanks
> >Prafulla
> >
> >
>
>
> --
> My research interests are distributed systems, parallel computing and
> bytecode based virtual machine.
>
> My profile:
> http://www.linkedin.com/in/coderplay
> My blog:
> http://coderplay.javaeye.com
>



-- 
My research interests are distributed systems, parallel computing and
bytecode based virtual machine.

My profile:
http://www.linkedin.com/in/coderplay
My blog:
http://coderplay.javaeye.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message