tajo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hyunsik Choi <hyun...@apache.org>
Subject Re: Problem starting http server when trying to run TajoMaster in IntelliJ
Date Mon, 13 Jan 2014 02:28:00 GMT
Hi Daniel,

Min Zhou submitted the fix
(https://issues.apache.org/jira/browse/TAJO-496), and the fix of this
problem was just committed to master branch (http://goo.gl/DH9sC3).

Thank you Daniel for the bug report.

- hyunsik

On Sat, Jan 11, 2014 at 3:28 AM, Jihoon Son <ghoonson@gmail.com> wrote:
> Hi, Daniel
> I got the same error.
> I'll find it as soon as possible.
>
> Thanks,
> Jihoon
>
>
> 2014/1/9 Daniel Einspanjer <deinspanjer@gmail.com>
>
>> I'd like to run TajoMaster directly inside IntelliJ so I can quickly
>> edit/compile code as well as debug.
>>
>> I set up a Run Configuration with the following settings:
>>
>> Application: TajoMaster
>> Main class: org.apache.tajo.master.TajoMaster
>> VM options: -Dtajo.test=TRUE
>> Working directory: /Users/deinspanjer/src/tajo
>> Environment variables:
>>   TAJO_HOME=/Users/deinspanjer/src/tajo/tajo-dist/target
>>   HADOOP_HOME=/Users/deinspanjer/src/hadoop-2.2.0
>> Use classpath of module: tajo-core-backend
>>
>>
>> I'm most unsure about the TAJO_HOME variable.
>>
>> When I try to run the config, I get a series of errors similar to this:
>> 2014-01-08 17:42:26,631 ERROR mortbay.log
>> (NativeMethodAccessorImpl.java:invoke0(?)) - Error starting handlers
>> java.lang.NoSuchFieldError: IS_SECURITY_ENABLED
>>
>> Here is a pastebin of the entire stacktrace:
>> http://pastebin.com/EU7JJT5T
>>
>>
>> Thank you for your time,
>> -Daniel
>>
>
>
>
> --
> Jihoon Son
>
> Database & Information Systems Group,
> Prof. Yon Dohn Chung Lab.
> Dept. of Computer Science & Engineering,
> Korea University
> 1, 5-ga, Anam-dong, Seongbuk-gu,
> Seoul, 136-713, Republic of Korea
>
> Tel : +82-2-3290-3580
> E-mail : jihoonson@korea.ac.kr

Mime
View raw message