tajo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "JaeHwa Jung (JIRA)" <j...@apache.org>
Subject [jira] [Created] (TAJO-429) UNION clause has a problem in sub-query.
Date Wed, 18 Dec 2013 09:53:07 GMT
JaeHwa Jung created TAJO-429:
--------------------------------

             Summary: UNION clause has a problem in sub-query.
                 Key: TAJO-429
                 URL: https://issues.apache.org/jira/browse/TAJO-429
             Project: Tajo
          Issue Type: Bug
            Reporter: JaeHwa Jung


If UNION clause write in SubQuery clause, TajoCli doesn't print any data.
I found that UNION query is right as follows:
{code:xml}
tajo> select a.id, a.name from table1 a union select b.id, b.name from table4 b ;
Progress: 100%, response time: 0.382 sec
final state: QUERY_SUCCEEDED, response time: 0.382 sec
result: hdfs://localhost:9010/tmp/tajo-blrunner/staging/q_1387355494232_0050/RESULT, 6 rows
(72 B)
id,  name
-------------------------------
12,  c02
13,  c03
14,  c04
15,  c05
16,  d01
17,  d02
1,  ooo
2,  ppp
3,  qqq
4,  rrr
5,  xxx
tajo> 
{code}

But, if I use UNION query in sub-query, there isn't any result data as follows:
{code:xml}
tajo> select * from (select a.id, a.name from table1 a union select b.id, b.name from table4
b) t;
Progress: 100%, response time: 0.396 sec
final state: QUERY_SUCCEEDED, response time: 0.396 sec
result: hdfs://localhost:9010/tmp/tajo-blrunner/staging/q_1387355494232_0051/RESULT, 11 rows
(0 B)
id,  name
-------------------------------
tajo> 
{code}



--
This message was sent by Atlassian JIRA
(v6.1.4#6159)

Mime
View raw message