tajo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jihoon Son <ghoon...@gmail.com>
Subject Re: starting problem tajo
Date Tue, 10 Dec 2013 07:27:29 GMT
Hi, Kishore
Would you let us know your development environment including java version,
maven version, and protocol buffer version?
It will help to find the cause of the error.

Thanks,
Jihoon


2013/12/10 Kishore kumar <kishore@techdigita.in>

> Hi Hyunsik,
>
> mvn clean package -DskipTests -Pdist -Dtar
> [INFO] Scanning for projects...
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Reactor Build Order:
> [INFO]
> [INFO] Tajo Main
> [INFO] Tajo Project POM
> [INFO] Tajo Common
> [INFO] Tajo Algebra
> [INFO] Tajo Rpc
> [INFO] Tajo Catalog Common
> [INFO] Tajo Catalog Client
> [INFO] Tajo Catalog Server
> [INFO] Tajo Core Storage
> [INFO] Tajo Core PullServer
> [INFO] Tajo Core Backend
> [INFO] Tajo Core
> [INFO] Tajo Catalog
> [INFO] Tajo Distribution
> [INFO]
>
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Building Tajo Main 0.8.0-SNAPSHOT
> [INFO]
> ------------------------------------------------------------------------
> Downloading:
>
> http://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-clean-plugin/2.5/maven-clean-plugin-2.5.pom
> Downloaded:
>
> http://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-clean-plugin/2.5/maven-clean-plugin-2.5.pom(4
> KB at 2.8 KB/sec)
> Downloading:
>
> http://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-plugins/22/maven-plugins-22.pom
> Downloaded:
>
> http://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-plugins/22/maven-plugins-22.pom(13
> KB at 23.5 KB/sec)
> Downloading:
>
> http://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-clean-plugin/2.5/maven-clean-plugin-2.5.jar
> Downloaded:
>
> http://repo.maven.apache.org/maven2/org/apache/maven/plugins/maven-clean-plugin/2.5/maven-clean-plugin-2.5.jar(25
> KB at 30.1 KB/sec)
> [INFO]
> [INFO] --- maven-enforcer-plugin:1.0:enforce (clean) @ tajo-main ---
> [INFO]
> [INFO] --- maven-clean-plugin:2.5:clean (default-clean) @ tajo-main ---
> Downloading:
>
> http://repo.maven.apache.org/maven2/org/apache/maven/maven-plugin-api/2.0.6/maven-plugin-api-2.0.6.pom
> Downloaded:
>
> http://repo.maven.apache.org/maven2/org/apache/maven/maven-plugin-api/2.0.6/maven-plugin-api-2.0.6.pom(2
> KB at 2.8 KB/sec)
> Downloading:
>
> http://repo.maven.apache.org/maven2/org/codehaus/plexus/plexus-utils/3.0/plexus-utils-3.0.jar
> Downloaded:
>
> http://repo.maven.apache.org/maven2/org/codehaus/plexus/plexus-utils/3.0/plexus-utils-3.0.jar(221
> KB at 115.3 KB/sec)
> [INFO]
> [INFO] --- maven-enforcer-plugin:1.0:enforce (default) @ tajo-main ---
> [INFO]
>
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Building Tajo Project POM 0.8.0-SNAPSHOT
> [INFO]
> ------------------------------------------------------------------------
> [INFO]
> [INFO] --- maven-enforcer-plugin:1.3:enforce (clean) @ tajo-project ---
> [INFO]
> [INFO] --- maven-clean-plugin:2.5:clean (default-clean) @ tajo-project ---
> [INFO]
> [INFO] --- maven-enforcer-plugin:1.3:enforce (default) @ tajo-project ---
> [INFO]
> [INFO] --- maven-enforcer-plugin:1.3:enforce (dist-enforce) @ tajo-project
> ---
> [INFO]
> [INFO] --- maven-site-plugin:3.3:attach-descriptor (attach-descriptor) @
> tajo-project ---
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Reactor Summary:
> [INFO]
> [INFO] Tajo Main ......................................... SUCCESS [6.171s]
> [INFO] Tajo Project POM .................................. FAILURE [2.526s]
> [INFO] Tajo Common ....................................... SKIPPED
> [INFO] Tajo Algebra ...................................... SKIPPED
> [INFO] Tajo Rpc .......................................... SKIPPED
> [INFO] Tajo Catalog Common ............................... SKIPPED
> [INFO] Tajo Catalog Client ............................... SKIPPED
> [INFO] Tajo Catalog Server ............................... SKIPPED
> [INFO] Tajo Core Storage ................................. SKIPPED
> [INFO] Tajo Core PullServer .............................. SKIPPED
> [INFO] Tajo Core Backend ................................. SKIPPED
> [INFO] Tajo Core ......................................... SKIPPED
> [INFO] Tajo Catalog ...................................... SKIPPED
> [INFO] Tajo Distribution ................................. SKIPPED
> [INFO]
> ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: 9.151s
> [INFO] Finished at: Tue Dec 10 12:26:42 IST 2013
> [INFO] Final Memory: 16M/176M
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-site-plugin:3.3:attach-descriptor
> (attach-descriptor) on project tajo-project: Unable to copy site
> descriptor:
> /usr/local/tajo/tajo-project/target/tajo-project-0.8.0-SNAPSHOT-site.xml
> (No such file or directory) -> [Help 1]
> [ERROR]
> [ERROR] To see the full stack trace of the errors, re-run Maven with the -e
> switch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR]
> [ERROR] For more information about the errors and possible solutions,
> please read the following articles:
> [ERROR] [Help 1]
> http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
> [ERROR]
> [ERROR] After correcting the problems, you can resume the build with the
> command
> [ERROR]   mvn <goals> -rf :tajo-project
>
> Protoc 2.4.1 ?
>
>
> Thanks,
> Kishore.
>
>
> On Tue, Dec 10, 2013 at 12:42 PM, Hyunsik Choi <hyunsik@apache.org> wrote:
>
> > Hi Kishore,
> >
> > the error log is too short to figure out the problem correctly. Could
> > you please show me longer error log?
> > And, I wonder you installed protoc 2.4.1
> >
> > - hyunsik
> >
> > On Tue, Dec 10, 2013 at 4:03 PM, Kishore kumar <kishore@techdigita.in>
> > wrote:
> > > Hi Hyunsik,
> > >
> > > Thanks for reply
> > >
> > > when I run #mvn clean package -DskipTests -Pdist -Dtar after downloaded
> > the
> > > source code with
> > >
> > > git clone
> https://git-wip-us.apache.org/repos/asf/incubator-tajo.gittajo
> > >
> > > cd tajo
> > >
> > > I am getting this error
> > >
> > > [ERROR] Failed to execute goal
> > > org.apache.maven.plugins:maven-site-plugin:3.3:attach-descriptor
> > > (attach-descriptor) on project tajo-project: Unable to copy site
> > > descriptor:
> > /usr/local/tajo/tajo-project/target/tajo-project-0.8.0-SNAPSHOT-site.xml
> > > (No such file or directory) -> [Help 1]
> > >
> > > what could be the problem, help me..
> > >
> > > Thanks,
> > >
> > > Kishore.
> > >
> > >
> > >
> > >
> > >
> > > On Mon, Dec 9, 2013 at 9:08 PM, Hyunsik Choi <hyunsik@apache.org>
> wrote:
> > >
> > >> Hi Kishore,
> > >>
> > >> First of all, thank you for your interest in Tajo.
> > >>
> > >> Your error message "Could not find or load main class
> > >> org.apache.tajo.master.TajoMaster." may indicates that there is no
> > >> class files or jar files. Did you build Tajo? 0.2 release is a source
> > >> release. If you didn't compile it, you couldn't launch a tajo cluster.
> > >>
> > >> If you want to read getting started tutorial, please see the below
> link.
> > >> http://tajo.incubator.apache.org/tajo-0.2.0-doc.html#GettingStarted
> > >>
> > >> Cheers,
> > >> Hyunsik
> > >>
> > >> On Mon, Dec 9, 2013 at 7:23 PM, Kishore kumar <kishore@techdigita.in>
> > >> wrote:
> > >> > Gave the user permissions on tajo home dir, localhost password issue
> > >> > resolved, pls help me on the Error: Could not find or load main
> class
> > >> > org.apache.tajo.master.TajoMaster.
> > >> >
> > >> > Thanks,
> > >> > Kishore.
> > >> >
> > >> >
> > >> > On Mon, Dec 9, 2013 at 2:56 PM, Kishore kumar <
> kishore@techdigita.in>
> > >> wrote:
> > >> >
> > >> >> Hi,
> > >> >>
> > >> >> I installed tajo-0.2.0-incubating version,
> > >> >>
> > >> >> when i run asking localhost password, I am using hadoop w/o any
> > problem
> > >> by
> > >> >> configure ssh with localhost, I checked log the error is
> > >> >>   Error: Could not find or load main class
> > >> >> org.apache.tajo.master.TajoMaster.
> > >> >>
> > >> >>
> > >> >> sudo ./start-tajo.sh
> > >> >> starting master, logging to
> > >> >>
> > >>
> >
> /usr/local/tajo/tajo-0.2.0-incubating/tajo-dist/src/main/bin/../logs/tajo-root-master-kishore-Vostro-1550.out
> > >> >> Error: Could not find or load main class
> > >> org.apache.tajo.master.TajoMaster
> > >> >> root@localhost's password:
> > >> >> root@localhost's password: localhost: Permission denied, please
> try
> > >> again.
> > >> >>
> > >> >> root@localhost's password: localhost: Permission denied, please
> try
> > >> again.
> > >> >>
> > >> >> localhost: Permission denied (publickey,password).
> > >> >>
> > >> >> any help ?
> > >> >>
> > >> >> Thanks,
> > >> >> Kishore.
> > >> >>
> > >> >>
> > >>
> >
>



-- 
Jihoon Son

Database & Information Systems Group,
Prof. Yon Dohn Chung Lab.
Dept. of Computer Science & Engineering,
Korea University
1, 5-ga, Anam-dong, Seongbuk-gu,
Seoul, 136-713, Republic of Korea

Tel : +82-2-3290-3580
E-mail : jihoonson@korea.ac.kr

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message