tajo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hyunsik Choi (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TAJO-323) Refactor inconsistent class and variable names
Date Sun, 24 Nov 2013 06:44:35 GMT

    [ https://issues.apache.org/jira/browse/TAJO-323?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13830882#comment-13830882
] 

Hyunsik Choi commented on TAJO-323:
-----------------------------------

QueryBlock already exists in order to represent a query block in a SQL query. 

A query consists multiple ExecutionBlocks, each of which is a step in a query. SubQuery in
current implementation is an in-progress state of an execution block. So, I would like to
name it ExecutionBlockInProgress.

Actually, I'm making a development document about query life cycle, hierarchy of query and
tasks, and their relationship for helping developers as well as this refactoring. With this
document, we can discuss it more detail.

> Refactor inconsistent class and variable names
> ----------------------------------------------
>
>                 Key: TAJO-323
>                 URL: https://issues.apache.org/jira/browse/TAJO-323
>             Project: Tajo
>          Issue Type: Task
>            Reporter: Hyunsik Choi
>             Fix For: 0.8-incubating
>
>
> There are inconsistent class and variable names. For example, QueryUnit and task are
used in a  mixing way, and QueryUnitAttempt and taskattempt are used in a  mixing way. They
reduce readability and make developers confuse.
> Now is the right time to correct them. The main object of this issue is to investigate
those inconsistent class and variable names and correct them.
> However, this work may make many conflicts. In order to minimize the code conflict, we
need to make a number of small separate refactors.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message