tajo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hyunsik Choi (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (TAJO-323) Refactor inconsistent class and variable names
Date Sun, 24 Nov 2013 05:09:36 GMT

    [ https://issues.apache.org/jira/browse/TAJO-323?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13830860#comment-13830860

Hyunsik Choi commented on TAJO-323:


I agree with your suggestion. I also think SubQuery makes guys confuse and does not represent
the exact meaning. I'll also create a jira issue for this.

> Refactor inconsistent class and variable names
> ----------------------------------------------
>                 Key: TAJO-323
>                 URL: https://issues.apache.org/jira/browse/TAJO-323
>             Project: Tajo
>          Issue Type: Task
>            Reporter: Hyunsik Choi
>             Fix For: 0.8-incubating
> There are inconsistent class and variable names. For example, QueryUnit and task are
used in a  mixing way, and QueryUnitAttempt and taskattempt are used in a  mixing way. They
reduce readability and make developers confuse.
> Now is the right time to correct them. The main object of this issue is to investigate
those inconsistent class and variable names and correct them.
> However, this work may make many conflicts. In order to minimize the code conflict, we
need to make a number of small separate refactors.

This message was sent by Atlassian JIRA

View raw message