systemml-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jean-Francis Roy (JIRA)" <j...@apache.org>
Subject [jira] [Created] (SYSTEMML-2138) mllearn/keras2caffe does not support Python 3
Date Thu, 08 Feb 2018 18:35:00 GMT
Jean-Francis Roy created SYSTEMML-2138:
------------------------------------------

             Summary: mllearn/keras2caffe does not support Python 3
                 Key: SYSTEMML-2138
                 URL: https://issues.apache.org/jira/browse/SYSTEMML-2138
             Project: SystemML
          Issue Type: Bug
            Reporter: Jean-Francis Roy


I am a new user of SystemML and I am not sure if this is supposed to work or not, but I am
surprised to see that I cannot follow the documentation's examples using Python 3.

When using `estimators.Keras2DML` function, it fails to import the `keras2caffe` module, as
it is compatible with Python 2 only.

Here are the parts of the code that aren't compatible with Python 3:
 * `imap` doesn't exist in itertools anymore, Python 3's `map` returns an iterator already.
Fix: use `future` package and import `map` from `builtins`.
 * Dictionary `keys()` now return an iterator that does not support indexing. Instead of `my_dict.keys()[0]`,
use `list(my_dict)[0]`.

 

With these changes I can get further using Python 3. I get an exception while converting a
model (that works using Keras directly), but this is likely to be unrelated with Python 2/3
support.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message