systemml-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Deron Eriksson <deroneriks...@gmail.com>
Subject Re: Dropping Java 6 and 7 support
Date Tue, 07 Mar 2017 15:27:54 GMT
+1.

Definitely makes sense for SystemML 1.0. In the Spark documentation: "Note
that support for Java 7 is deprecated as of Spark 2.0.0 and may be removed
in Spark 2.2.0."

Deron



On Mon, Mar 6, 2017 at 11:15 PM, Berthold Reinwald <reinwald@us.ibm.com>
wrote:

> +1 on removing java 6 and 7.
>
> Regards,
> Berthold Reinwald
> IBM Almaden Research Center
> office: (408) 927 2208; T/L: 457 2208
> e-mail: reinwald@us.ibm.com
>
>
>
> From:   Matthias Boehm <mboehm7@googlemail.com>
> To:     dev@systemml.incubator.apache.org
> Date:   03/06/2017 10:58 PM
> Subject:        Dropping Java 6 and 7 support
>
>
>
> Hi all,
>
> I'd like to drop the support for Java 6 and 7 in our SystemML 1.0 release.
> Our build still refers to a java compliance level 6, which has not been
> changed for more than 5 years now. Spark >= 1.5 anyway requires Java 7 and
> there has been some discussion on removing Java 7 as well because it
> reached end of life in April 2015. Moving to Java 8 would allow us to
> modernize the code base going forward and the 1.0 release would be the
> perfect time for this change.
>
> Regards,
> Matthias
>
>
>
>
>


-- 
Deron Eriksson
Spark Technology Center
http://www.spark.tc/

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message