syncope-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Philip W. Dalrymple III (Jira)" <j...@apache.org>
Subject [jira] [Created] (SYNCOPE-1491) a install WITHOUT tests appears to be needed before the tests can be run
Date Mon, 09 Sep 2019 14:54:00 GMT
Philip W. Dalrymple III created SYNCOPE-1491:
------------------------------------------------

             Summary: a install WITHOUT tests appears to be needed before the tests can be
run
                 Key: SYNCOPE-1491
                 URL: https://issues.apache.org/jira/browse/SYNCOPE-1491
             Project: Syncope
          Issue Type: Bug
          Components: documentation
    Affects Versions: 3.0.0
            Reporter: Philip W. Dalrymple III


I am just starting to set up a build of Syncope from source.

I forked the Github and set up a new Centos 7

Maven home: /opt/apache-maven-3.6.2
Java version: 12.0.2, vendor: Oracle Corporation, runtime: /opt/jdk-12.0.2
Default locale: en_US, platform encoding: UTF-8
OS name: "linux", version: "3.10.0-957.27.2.el7.x86_64", arch: "amd64", family: "unix"

I did the 

mvn clean install

But that errored out in a test that needed the Core before the core had been build.

I found that doing a mvn -PskipTests,all then a 
mvn -PskipTests,install

completes and then the 

mvn clean install works fine.

This is my first day in Maven so I am not sure what is going on.



--
This message was sent by Atlassian Jira
(v8.3.2#803003)

Mime
View raw message