syncope-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SYNCOPE-1220) Support Groovy implementations in the Netbeans IDE plugin
Date Fri, 17 Aug 2018 08:47:00 GMT

    [ https://issues.apache.org/jira/browse/SYNCOPE-1220?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16583601#comment-16583601
] 

ASF GitHub Bot commented on SYNCOPE-1220:
-----------------------------------------

GitHub user rohanjulka19 opened a pull request:

    https://github.com/apache/syncope/pull/82

    [SYNCOPE-1220] Support Groovy implementation in the Netbeans plugin

    

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/rohanjulka19/syncope SYNCOPE-1220

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/syncope/pull/82.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #82
    
----
commit 05aef448b98c72949d0bc209df4ac42b7c72b2c7
Author: rohan julka <rohanjulka19@...>
Date:   2018-08-14T07:20:14Z

    [SYNCOPE-1220] Support Groovy implementation in the Netbeans plugin

----


> Support Groovy implementations in the Netbeans IDE plugin
> ---------------------------------------------------------
>
>                 Key: SYNCOPE-1220
>                 URL: https://issues.apache.org/jira/browse/SYNCOPE-1220
>             Project: Syncope
>          Issue Type: New Feature
>          Components: ide
>            Reporter: Francesco Chicchiriccò
>            Priority: Major
>              Labels: gsoc2018, netbeans
>             Fix For: 2.1.2, 3.0.0
>
>         Attachments: syncope-ide-netbeans-2.1.0-SNAPSHOT.nbm, syncope_error.PNG
>
>
> SYNCOPE-956 introduced the possibility to provide Groovy-based implementations.
>  The Netbeans IDE plugin should be extended to support this.
> This issue basically starts from the work already done for SYNCOPE-808. This means that
there is an already existing netbeans plugin for Syncope. For more info please see  [this|https://syncope.apache.org/docs/reference-guide.html#netbeans-ide-plugin] 
and  [https://syncope.apache.org/docs/getting-started.html#netbeans-ide-plugin]
>  Please install this plugin and let it work with your local Syncope installation, in
order to understand how it works and interacts with Syncope.
> The goal is to improve the current netbeans plugin to create and edit (also format) Groovy
scripts used to extend default Syncope behavior. Refer to SYNCOPE-956 to have an idea of
what I'm talking about. Basically this means that some default or "open to implementation"
functionalities of Syncope Idm can be improved or developed by pluggin in groovy scripts.
This mechanism allows to develop custom behaviors for Syncope, based on specific project requirements. [Here|http://syncope.apache.org/docs/reference-guide.html#customization-core] is
the list of customizable features.
> Since [Netbeans 9|https://cwiki.apache.org/confluence/display/NETBEANS/Apache+NetBeans+9.0+Beta] is
near to be released, develop this plugin referring to Netbeans 9 (currently beta).



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message