syncope-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From tmess567 <...@git.apache.org>
Subject [GitHub] syncope pull request #28: Syncope-809 GSoC Project (Eclipse Plugin for Apach...
Date Thu, 21 Jul 2016 06:23:29 GMT
Github user tmess567 commented on a diff in the pull request:

    https://github.com/apache/syncope/pull/28#discussion_r71652297
  
    --- Diff: ide/eclipse/bundles/org.apache.syncope.ide.eclipse.plugin/META-INF/MANIFEST.MF
---
    @@ -0,0 +1,48 @@
    +Manifest-Version: 1.0
    +Bundle-ManifestVersion: 2
    +Bundle-Name: Plugin
    +Bundle-SymbolicName: org.apache.syncope.ide.eclipse.plugin;singleton:=true
    +Bundle-Version: 2.0.0.qualifier
    --- End diff --
    
    The qualifier maps to STANDALONE
    Which is why the jar, the archive and the p2 site built is named "org.apache.syncope.ide.eclipse.plugin-2.0.0-SNAPSHOT"
    
    The version number can be changed using a plugin.properties file, but this will again
lead to the same problems as faced in [this issue](https://github.com/tmess567/SYNCOPE-809/issues/9).

    
    Also, this version number must be the same as in the pom or else it will throw the following
error.
    ```
    [ERROR] Failed to execute goal org.eclipse.tycho:tycho-packaging-plugin:0.25.0:validate-version
(default-validate-version) on project org.apache.syncope.ide.eclipse.plugin: Unqualified OSGi
version 1.0.0.qualifier must match unqualified Maven version 2.0.0-SNAPSHOT for SNAPSHOT builds
    ```
    It would be better if this remains static and is changed whenever required.
    



---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

Mime
View raw message