syncope-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Colm O hEigeartaigh <cohei...@apache.org>
Subject REST API authentication in 2.0.0
Date Tue, 28 Jun 2016 14:40:49 GMT
Hi,

Just wanted to check before filing a JIRA. With the latest 2.0.0-SNAPSHOT,
I noticed that accessing the REST API without supplying a username/password
returns 403 as opposed to the old 401.

wget http://localhost:9080/syncope/rest/users

--2016-06-28 15:40:01--  http://localhost:9080/syncope/rest/users
Resolving localhost (localhost)... 127.0.0.1
Connecting to localhost (localhost)|127.0.0.1|:9080... connected.
HTTP request sent, awaiting response... 403
2016-06-28 15:40:01 ERROR 403: (no description).

Whereas with 1.2.7:

wget http://localhost:9080/syncope/rest/users
--2016-06-28 15:29:42--  http://localhost:9080/syncope/rest/users
Resolving localhost (localhost)... 127.0.0.1
Connecting to localhost (localhost)|127.0.0.1|:9080... connected.
HTTP request sent, awaiting response... 401 Unauthorized

Username/Password Authentication Failed.

This means that if you open up a web browser and try to access say:

http://localhost:9080/syncope/rest/users

a pop-up windows does not appear for the user to enter the user/password.
Was there a reason for this change or will I file a bug?

Thanks,

Colm.


-- 
Colm O hEigeartaigh

Talend Community Coder
http://coders.talend.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message