syncope-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Francesco Chicchiriccò (JIRA) <j...@apache.org>
Subject [jira] [Commented] (SYNCOPE-776) Standalone 2.0.0-M1 does not start up
Date Mon, 14 Mar 2016 15:39:33 GMT

    [ https://issues.apache.org/jira/browse/SYNCOPE-776?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15193496#comment-15193496
] 

Francesco Chicchiriccò commented on SYNCOPE-776:
------------------------------------------------


As a temporary workaround, it is required to:

(1) replace {{uwfAdapter=org.apache.syncope.core.workflow.activiti.ActivitiUserWorkflowAdapter}}

with

{{uwfAdapter=org.apache.syncope.core.workflow.java.DefaultUserWorkflowAdapter}}

in {{webapps/syncope/WEB-INF/classes/workflow.properties}}

(2) replace 

{code}
userProvisioningManager=org.apache.syncope.core.provisioning.camel.CamelUserProvisioningManager
groupProvisioningManager=org.apache.syncope.core.provisioning.camel.CamelGroupProvisioningManager
anyObjectProvisioningManager=org.apache.syncope.core.provisioning.camel.CamelAnyObjectProvisioningManager
{code}

with

{code}
userProvisioningManager=org.apache.syncope.core.provisioning.java.DefaultUserProvisioningManager
groupProvisioningManager=org.apache.syncope.core.provisioning.java.DefaultGroupProvisioningManager
anyObjectProvisioningManager=org.apache.syncope.core.provisioning.java.DefaultAnyObjectProvisioningManager
{code}

in {{webapps/syncope/WEB-INF/classes/provisioning.properties}}

(3) remove the following lines

{code}
<ACT_RU_EXECUTION SUSPENSION_STATE_="1" IS_EVENT_SCOPE_="0" IS_SCOPE_="1" IS_CONCURRENT_="0"
IS_ACTIVE_="1" ACT_ID_="active" PROC_DEF_ID_="userWorkflow:1:4" PROC_INST_ID_="4" REV_="2"
ID_="4"/>
<ACT_RU_TASK CREATE_TIME_="2013-02-25T17:19:03+0100" PRIORITY_="50" TASK_DEF_KEY_="active"
NAME_="Active" PROC_DEF_ID_="userWorkflow:1:4" PROC_INST_ID_="4" EXECUTION_ID_="4" REV_="2"
ID_="5"/>
<ACT_RU_EXECUTION SUSPENSION_STATE_="1" IS_EVENT_SCOPE_="0" IS_SCOPE_="1" IS_CONCURRENT_="0"
IS_ACTIVE_="1" ACT_ID_="active" PROC_DEF_ID_="userWorkflow:1:4" PROC_INST_ID_="6" REV_="2"
ID_="6"/>
<ACT_RU_TASK CREATE_TIME_="2013-02-25T17:19:03+0100" PRIORITY_="50" TASK_DEF_KEY_="active"
NAME_="Active" PROC_DEF_ID_="userWorkflow:1:4" PROC_INST_ID_="6" EXECUTION_ID_="6" REV_="2"
ID_="7"/>
<ACT_RU_EXECUTION SUSPENSION_STATE_="1" IS_EVENT_SCOPE_="0" IS_SCOPE_="1" IS_CONCURRENT_="0"
IS_ACTIVE_="1" ACT_ID_="active" PROC_DEF_ID_="userWorkflow:1:4" PROC_INST_ID_="8" REV_="2"
ID_="8"/>
<ACT_RU_TASK CREATE_TIME_="2013-02-25T17:19:03+0100" PRIORITY_="50" TASK_DEF_KEY_="active"
NAME_="Active" PROC_DEF_ID_="userWorkflow:1:4" PROC_INST_ID_="8" EXECUTION_ID_="8" REV_="2"
ID_="9"/>
<ACT_RU_EXECUTION SUSPENSION_STATE_="1" IS_EVENT_SCOPE_="0" IS_SCOPE_="1" IS_CONCURRENT_="0"
IS_ACTIVE_="1" ACT_ID_="active" PROC_DEF_ID_="userWorkflow:1:4" PROC_INST_ID_="10" REV_="2"
ID_="10"/>
<ACT_RU_TASK CREATE_TIME_="2013-02-25T17:19:03+0100" PRIORITY_="50" TASK_DEF_KEY_="active"
NAME_="Active" PROC_DEF_ID_="userWorkflow:1:4" PROC_INST_ID_="10" EXECUTION_ID_="10" REV_="2"
ID_="11"/>
<ACT_RU_EXECUTION SUSPENSION_STATE_="1" IS_EVENT_SCOPE_="0" IS_SCOPE_="1" IS_CONCURRENT_="0"
IS_ACTIVE_="1" ACT_ID_="active" PROC_DEF_ID_="userWorkflow:1:4" PROC_INST_ID_="12" REV_="2"
ID_="12"/>
<ACT_RU_TASK CREATE_TIME_="2013-02-25T17:19:03+0100" PRIORITY_="50" TASK_DEF_KEY_="active"
NAME_="Active" PROC_DEF_ID_="userWorkflow:1:4" PROC_INST_ID_="12" EXECUTION_ID_="12" REV_="2"
ID_="13"/>
{code}

from {{webapps/syncope/WEB-INF/classes/domains/MasterContent.xml}}

> Standalone 2.0.0-M1 does not start up
> -------------------------------------
>
>                 Key: SYNCOPE-776
>                 URL: https://issues.apache.org/jira/browse/SYNCOPE-776
>             Project: Syncope
>          Issue Type: Bug
>          Components: standalone
>    Affects Versions: 2.0.0-M1
>            Reporter: Francesco Chicchiriccò
>             Fix For: 2.0.0
>
>
> Even following the appropriate [instructions|http://syncope.apache.org/docs/getting-started.html#standalone],
the standalone distribution does not allow Tomcat to successfully start with all Syncope apps
correctly deployed.
> The problem is that some configuration files are set for using Activiti and Camel, where
JAR counterparts are not bundled.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message