synapse-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rajan Mahadevan <ra...@pobox.com>
Subject Building Synapse From Source Snapshot
Date Thu, 24 Sep 2009 13:15:33 GMT
Hi,
I checked out synapse sources from
http://svn.apache.org/repos/asf/synapse/branches/1.3/ and built the
sources with mvn clean install. I also removed the tests in the bsf
and javascript packages and the build and tests worked.
I unzipped the C:\synapse-1.3\modules\distribution\target\synapse-1.3.0-SNAPSHOT-bin.zip
in my c:\ directory and when I launch synapse, then I get the
following error.
C:\synapse-1.3.0-SNAPSHOT\bin>synapse.bat -sample 0
"Starting Synapse/Java ..."
Using SYNAPSE_HOME:        C:\SYNAPS~1.0-S\bin\..
Using JAVA_HOME:       C:\jdk1.5.0_15
--> Wrapper Started as Console
Launching a JVM...
Wrapper (Version 3.2.3) http://wrapper.tanukisoftware.org
  Copyright 1999-2006 Tanuki Software, Inc.  All Rights Reserved.

WrapperSimpleApp: Unable to locate the class org.apache.synapse.SynapseServer: j
ava.lang.NoClassDefFoundError: org/slf4j/LoggerFactory

WrapperSimpleApp Usage:
  java org.tanukisoftware.wrapper.WrapperSimpleApp {app_class} [app_arguments]

Where:
  app_class:      The fully qualified class name of the application to run.
  app_arguments:  The arguments that would normally be passed to the
                  application.
<-- Wrapper Stopped
Press any key to continue . . .

When I try mvn assembly:assembly -Drelease -o -Dmaven.test.skip=true
at the parent module directory, then the distribution module still
builds fine but the build fails at

[INFO] Building Apache Synapse - Package archetype
[INFO] ------------------------------------------------------------------------
[WARNING] Removing: jar from forked lifecycle, to prevent recursive invocation.
[INFO] [resources:resources]
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] Copying 9 resources
[INFO] [resources:testResources]
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] skip non existing resourceDirectory C:\synapse-1.3\modules\packaging\pack
age-archetype\src\test\resources
[INFO] Setting property: classpath.resource.loader.class => 'org.codehaus.plexus
.velocity.ContextClassLoaderResourceLoader'.
[INFO] Setting property: velocimacro.messages.on => 'false'.
[INFO] Setting property: resource.loader => 'classpath'.
[INFO] Setting property: resource.manager.logwhenfound => 'false'.
[INFO] [archetype:jar]
[INFO] [archetype:add-archetype-metadata]
[INFO] [assembly:assembly]
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Error reading assemblies: No assembly descriptors found.

[INFO] ------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 2 minutes 5 seconds
[INFO] Finished at: Thu Sep 24 09:04:48 EDT 2009
[INFO] Final Memory: 53M/63M
[INFO] ------------------------------------------------------------------------

I am trying to get the latest build of Synapse snapshots going to
check if the Http NIO Reactor  looping problem still exists for bad
http request.

Rajan

Mime
View raw message