synapse-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vanjikumaran Sivajothy <vanjikuma...@gmail.com>
Subject Regard the properties in Synapse
Date Fri, 03 Jun 2016 04:16:43 GMT
Hi Devs,

I am currently looking into the SYNAPSE-818, While going through with code,
I notice inconsistency in the property naming across the board.

These properties are following like CamelCap or camelBack or CAP_VAR, Why
this much of variation?. I understand that SOAP headers and HTTP related
headers could be exceptional.

Example of inconsistency :- preserveProcessedHeaders, OperationName


IMO, other properties that helps to control the flow should not vary in
naming convention. So I am proposing to make it consistent across the
synapse (Of course with backward compatibility).

WDYT?

[1]https://issues.apache.org/jira/browse/SYNAPSE-818

-- 
Best Regards,
Vanji

Mime
View raw message