synapse-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hiranya Jayathilaka (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SYNAPSE-894) [Iterate Mediator] - Unwanted tags attached to the payload if preservePayload="false"
Date Tue, 16 Jul 2013 18:06:49 GMT

    [ https://issues.apache.org/jira/browse/SYNAPSE-894?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13710013#comment-13710013
] 

Hiranya Jayathilaka commented on SYNAPSE-894:
---------------------------------------------

I'm not able to reproduce this issue in the latest trunk. This is the log output I get when
I try your scenario:

2013-07-16 11:00:06,932 [-] [PassThroughMessageProcessor-1]  INFO LogMediator MESSAGE = ##Iterating
2013-07-16 11:00:06,957 [-] [PassThroughMessageProcessor-1]  INFO LogMediator To: /services/IteratorProxy,
WSAction: urn:getQuote, SOAPAction: urn:getQuote, MessageID: urn:uuid:788512ab-a596-46e7-89f9-8e97df538fc9,
Direction: request, Envelope: <?xml version='1.0' encoding='utf-8'?><soapenv:Envelope
xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"><soapenv:Body><m0:getQuote
xmlns:m0="http://services.samples">             <m0:request>                <m0:symbol>IBM</m0:symbol>
            </m0:request>          </m0:getQuote></soapenv:Body></soapenv:Envelope>
2013-07-16 11:00:06,958 [-] [PassThroughMessageProcessor-1]  INFO LogMediator MESSAGE = ##Iterating
2013-07-16 11:00:06,958 [-] [PassThroughMessageProcessor-1]  INFO LogMediator To: /services/IteratorProxy,
WSAction: urn:getQuote, SOAPAction: urn:getQuote, MessageID: urn:uuid:651a57e7-6cd3-4e0e-9185-730fe1809231,
Direction: request, Envelope: <?xml version='1.0' encoding='utf-8'?><soapenv:Envelope
xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"><soapenv:Body><m0:getQuote
xmlns:m0="http://services.samples">             <m0:request>                <m0:symbol>IBM3</m0:symbol>
            </m0:request>          </m0:getQuote></soapenv:Body></soapenv:Envelope>
2013-07-16 11:00:06,959 [-] [PassThroughMessageProcessor-1]  INFO LogMediator MESSAGE = ##Iterating
2013-07-16 11:00:06,959 [-] [PassThroughMessageProcessor-1]  INFO LogMediator To: /services/IteratorProxy,
WSAction: urn:getQuote, SOAPAction: urn:getQuote, MessageID: urn:uuid:05c3638f-9da9-4f1d-9892-59743c9c6cbf,
Direction: request, Envelope: <?xml version='1.0' encoding='utf-8'?><soapenv:Envelope
xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"><soapenv:Body><m0:getQuote
xmlns:m0="http://services.samples">             <m0:request>                <m0:symbol>DLL</m0:symbol>
            </m0:request>          </m0:getQuote></soapenv:Body></soapenv:Envelope>

Looks like things are working as expected in the trunk. Your issue could have been due to
a problem in an old Axiom version.
                
> [Iterate Mediator] - Unwanted tags attached to the payload if preservePayload="false"
> -------------------------------------------------------------------------------------
>
>                 Key: SYNAPSE-894
>                 URL: https://issues.apache.org/jira/browse/SYNAPSE-894
>             Project: Synapse
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 2.1
>         Environment: ubuntu 12.04
>            Reporter: Dushan Sachinda Abeyruwan
>            Assignee: Hiranya Jayathilaka
>            Priority: Critical
>             Fix For: FUTURE
>
>         Attachments: IterateMediator.java.patch
>
>
> 1. I have a request as below 
> <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
>    <soapenv:Body>
>       <m0:requestQuotes xmlns:m0="http://services.samples">
>          <m0:getQuote>
>             <m0:request>
>                <m0:symbol>IBM</m0:symbol>
>             </m0:request>
>          </m0:getQuote>
>          <m0:getQuote>
>             <m0:request>
>                <m0:symbol>IBM3</m0:symbol>
>             </m0:request>
>          </m0:getQuote>
>         <m0:getQuote>
>             <m0:request>
>                <m0:symbol>DLL</m0:symbol>
>             </m0:request>
>          </m0:getQuote>
>       </m0:requestQuotes>
>    </soapenv:Body>
> </soapenv:Envelope>
> 2. I specified the iterate configuration as following. 
>  <proxy name="IteratorProxy" transports="https http" startOnLoad="true" trace="disable">
>         <description/>
>         <target>
>             <inSequence>
>                 <iterate xmlns:m0="http://services.samples" id="iterate1" expression="//m0:requestQuotes/m0:getQuote">
>                     <target>
>                         <sequence>
>                             <log level="custom">
>                                 <property name="MESSAGE" value="##Iterating"/>
>                             </log>
>                             <log level="full"/>
>                             <send receive="StockResponseSequence">
>                                 <endpoint>
>                                     <address uri="http://localhost:9001/services/SimpleStockQuoteService"/>
>                                 </endpoint>
>                             </send>
>                         </sequence>
>                     </target>
>                 </iterate>
>             </inSequence>
>             <outSequence>
>                 <send/>
>             </outSequence>
>         </target>
>         <publishWSDL uri="http://localhost:9000/services/SimpleStockQuoteService?wsdl"/>
> </proxy> 
> <sequence name="StockResponseSequence">
>         <aggregate id="iterate1">
>             <completeCondition>
>                 <messageCount min="-1" max="-1"/>
>             </completeCondition>
>             <onComplete xmlns:ns="http://services.samples" expression="//ns:getQuoteResponse">
>                    <send/>
>             </onComplete>
>         </aggregate>
>     </sequence>
> 4. When invoked, I see a message like below 
> <?xml version='1.0' encoding='utf-8'?> 
> <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"> 
> <soapenv:Body> 
>        <m0:requestQuotes xmlns:m0="http://services.samples"> ----> Is this required?

> <m0:getQuote> 
> </m0:getQuote> 
> </m0:requestQuotes> 
>         <m0:request xmlns:m0="http://services.samples"> 
> <m0:symbol>IBM4</m0:symbol> 
>         </m0:request> 
> </soapenv:Body> 
> </soapenv:Envelope> 
> Why does it attach <m0:requestQuotes xmlns:m0="http://services.samples"><m0:getQuote></m0:getQuote></m0:requestQuotes>
part to the XML? Is this the correct behavior? 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@synapse.apache.org
For additional commands, e-mail: dev-help@synapse.apache.org


Mime
View raw message